Bug 67687 - SBLive! does not work after kernel upgrade
Summary: SBLive! does not work after kernel upgrade
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-29 11:24 UTC by Need Real Name
Modified: 2007-04-18 16:43 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-27 22:17:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-06-29 11:24:55 UTC
After an upgrade to kernel-2.4.9-34
sblive stopped working.
both drivers  emu10k1 and  emu10k1_new
give noice while playing .wav files.
There was no such problem with kernel-2.4.7-10

The problem is similar to closed bug:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=53803
It was not really fixed.

Strange thing that while 

play file.wav (which uses /dev/audio )

gives just noice the command 

/usr/bin/esdplay file.wav (which uses /dev/dsp)

plays sound OK

Comment 1 Need Real Name 2002-06-29 16:50:20 UTC
Sometimes after running

/usr/bin/esdplay file.wav

few times the command 

play file.wav

starts producing the right sound.
But after running play file.wav
few times the same noise is starting again
on play file.wav




Comment 2 Need Real Name 2002-06-29 17:20:02 UTC
It looks like some uninitialized variable
somewhere.
play file.wav may work OK, and may not work OK.
but right after edsplay file.wav it always OK.

another note:
esdplay file.way is almost OK,
sometimes there is an extra high frequency noice,
but this happen seldomly.


Note You need to log in before you can comment on or make changes to this bug.