Bug 676942 - Text mode missing dependencies dialog out uses single column
Summary: Text mode missing dependencies dialog out uses single column
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Sivák
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker RejectedNTH
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-11 23:05 UTC by Orion Poplawski
Modified: 2011-05-17 15:07 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-05-17 15:07:51 UTC


Attachments (Terms of Use)

Description Orion Poplawski 2011-02-11 23:05:27 UTC
Description of problem:

During text mode install got missing dependencies warning.  Output is listed in one column, e.g.:

l
y
x
-
2
.
0
.
0


and so on.

Version-Release number of selected component (if applicable):
15.19

Comment 1 Orion Poplawski 2011-02-11 23:28:54 UTC
After this the install errors with:

There was an error running your transaction for the following reason(s0: required package.

but the text scroll area is empty.  Logs indicate an issue with the lyx missing dependencies:

16:12:40,694 ERR anaconda: required package: libboost_regex-mt.so.1.44.0()(64bit) is needed by lyx-2.0.0-0.11.beta3.fc15.x86_64
16:12:40,695 ERR anaconda: required package: libboost_signals-mt.so.1.44.0()(64bit) is needed by lyx-2.0.0-0.11.beta3.fc15.x86_64


This is new behavior too, isn't it?  I thought it would continue in previous releases.  No option to continue here.

Comment 2 Chris Lumens 2011-02-14 02:41:59 UTC
Martin - This is fixed by 4a2b00e7376f200de85f978b2dbccfb27903d9a9 from rhel6-branch that just needs to be cherry-picked.

Orion - You can't continue there like you can in graphical mode because there's no text mode package selection screen to go back to.

Comment 3 James Laska 2011-02-14 19:38:23 UTC
Adding to the NTH F15Alpha-accepted NICE-TO-HAVE tracker.  It doesn't appear that the text corruption is fatal.  IF it were, it would easily fall into the release criteria as a blocker:

   "The installer must be able to complete an installation using 
    the text, graphical and VNC installation interfaces"

https://fedoraproject.org/wiki/Fedora_15_Alpha_Release_Criteria

Orion, have you filed a bug for the package dependency issue yet, that would be a blocker bug.

Comment 4 Chris Lumens 2011-02-14 20:13:40 UTC
This will be fixed in the next build of anaconda for F15 alpha, which I believe
will be 15.20.1.  James - I can produce an updates.img if required, or you can grab the fix from f15-alpha-branch.

Comment 5 Orion Poplawski 2011-02-14 20:21:54 UTC
(In reply to comment #3)
> Orion, have you filed a bug for the package dependency issue yet, that would be
> a blocker bug.

lyx has been fixed.

Comment 6 Robyn Bergeron 2011-02-18 18:55:50 UTC
Per 2011-02-18 Alpha blocker meeting:

#agreed 676942 - RejectedBlocker, RejectedNTH - a mal-formed package dep dialog in text-mode doesn't meet criteria

Comment 7 James Laska 2011-05-17 14:01:53 UTC
This issue should be resolved, however it may will need a manually broken repo to confirm.

Comment 8 Orion Poplawski 2011-05-17 15:07:51 UTC
Confirmed fixed in 15.31.  (There are plenty of broken deps to test with :().


Note You need to log in before you can comment on or make changes to this bug.