Bug 676954 - gpgme-config outputs -lassuan
Summary: gpgme-config outputs -lassuan
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gpgme
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-12 01:54 UTC by Bill Nottingham
Modified: 2014-03-17 03:26 UTC (History)
3 users (show)

Fixed In Version: gpgme-1.3.0-4.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-26 05:10:47 UTC


Attachments (Terms of Use)
spec patch (1.05 KB, patch)
2011-02-12 01:55 UTC, Bill Nottingham
no flags Details | Diff

Description Bill Nottingham 2011-02-12 01:54:37 UTC
Description of problem:

... therefore requiring libassuan-devel to be installed in the buildroot, otherwise builds break. (http://koji.fedoraproject.org/koji/getfile?taskID=2834060&name=build.log is an example.)

Will attach a spec patch to add a requirement; alternatively, gpgme-config could elide the -l line.

Version-Release number of selected component (if applicable):

gpgme-1.3.0-1

How reproducible:

100%

Steps to Reproduce:
1. Try to build kdepimlibs, or something similar
  
Actual results:

Fails due to missing libassuan-devel.

Expected results:

Succeeds, one way or another.

Comment 1 Bill Nottingham 2011-02-12 01:55:08 UTC
Created attachment 478339 [details]
spec patch

Comment 2 Rex Dieter 2011-02-13 21:16:31 UTC
Added something close to that in 1.3.0-2 build coming shortly.

Comment 3 Fedora Update System 2011-02-13 21:27:43 UTC
gpgme-1.3.0-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gpgme-1.3.0-2.fc15

Comment 4 Fedora Update System 2011-03-03 02:45:48 UTC
gpgme-1.3.0-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2011-03-18 12:29:47 UTC
gpgme-1.3.0-4.fc15,kdepim-4.4.10-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gpgme-1.3.0-4.fc15,kdepim-4.4.10-2.fc15

Comment 6 Fedora Update System 2011-03-26 05:10:43 UTC
gpgme-1.3.0-4.fc15, kdepim-4.4.10-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.