Bug 676968 - system halts after first reboot during kickstart installation
system halts after first reboot during kickstart installation
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
AcceptedBlocker
: Reopened
: 682765 695445 (view as bug list)
Depends On:
Blocks: 494832 F15Beta/F15BetaBlocker
  Show dependency treegraph
 
Reported: 2011-02-12 01:05 EST by Hongqing Yang
Modified: 2011-10-05 12:17 EDT (History)
8 users (show)

See Also:
Fixed In Version: anaconda-15.26-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-06 10:54:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
system halt screenshot (9.03 KB, image/png)
2011-02-12 01:05 EST, Hongqing Yang
no flags Details
anaconda log (36.42 KB, text/plain)
2011-02-12 01:06 EST, Hongqing Yang
no flags Details
install log (16.58 KB, text/plain)
2011-02-12 01:07 EST, Hongqing Yang
no flags Details
anaconda program log (18.92 KB, text/plain)
2011-02-12 01:09 EST, Hongqing Yang
no flags Details
anaconda syslog (47.72 KB, text/plain)
2011-02-12 01:09 EST, Hongqing Yang
no flags Details
install syslog (5.26 KB, text/plain)
2011-02-12 01:10 EST, Hongqing Yang
no flags Details
kickstart configuration (1.95 KB, text/plain)
2011-02-13 21:27 EST, Hongqing Yang
no flags Details
anaconda-logs.tar.gz (69.20 KB, application/x-gzip)
2011-03-31 02:13 EDT, He Rui
no flags Details

  None (edit)
Description Hongqing Yang 2011-02-12 01:05:03 EST
Created attachment 478354 [details]
system halt screenshot

Description of problem:

After kickstart installation, system halts after first reboot  

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. kickstart install F-15
2. reboot
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Hongqing Yang 2011-02-12 01:06:36 EST
Created attachment 478356 [details]
anaconda log
Comment 2 Hongqing Yang 2011-02-12 01:07:15 EST
Created attachment 478357 [details]
install log
Comment 3 Hongqing Yang 2011-02-12 01:09:08 EST
Created attachment 478358 [details]
anaconda program log
Comment 4 Hongqing Yang 2011-02-12 01:09:35 EST
Created attachment 478359 [details]
anaconda syslog
Comment 5 Hongqing Yang 2011-02-12 01:10:23 EST
Created attachment 478360 [details]
install syslog
Comment 6 He Rui 2011-02-13 02:28:54 EST
Yeah, I can reproduce it as well using kickstart to install F15-alpha-tc1. It happens when clicking 'Reboot button' after package installation finished.
Comment 7 Chris Lumens 2011-02-13 12:33:01 EST
What's your kickstart file look like?
Comment 8 Hongqing Yang 2011-02-13 21:27:22 EST
Created attachment 478537 [details]
kickstart configuration
Comment 9 Chris Lumens 2011-02-15 12:55:34 EST
Halting is the default action for kickstart when nothing else is specified, though:

https://fedoraproject.org/wiki/Anaconda/Kickstart#halt
Comment 10 James Laska 2011-02-15 16:32:22 EST
I'm experiencing the same issue, but I have 'reboot' in my kickstart file.  I was doing a cmdline install test, so I'm not able to grab any logs off the system.  I'll see what I can uncover ...

# Firewall configuration
firewall --disabled
# Use network installation
url --url="http://dell-t5400.test.redhat.com/cobbler/ks_mirror/F-15-Alpha-x86_64"
# Root password
rootpw --iscrypted $1$xafj7qlW$6swjxMwu0po47drJVRcIZ/
# System keyboard
keyboard us
# System language
lang en_US
# Installation logging level
logging --level=info
# Reboot after installation
reboot
# System timezone
timezone --isUtc America/New_York
# System bootloader configuration
bootloader --location=mbr
autopart
# Partition clearing information
clearpart --all --initlabel

%packages --default --ignoremissing
%end
Comment 11 Hongqing Yang 2011-02-16 03:11:59 EST
reproduced with kickstart file

#install a fresh system rather than upgrade an existing system
install
# Perform the kickstart installation in text mode
#text
graphical
# Install from an installation tree on a remote server via FTP or HTTP
cdrom
#fire wall configuration
firewall --disabled
# Root password
rootpw ``````
# System keyboard
keyboard us
# System language
lang en_US
# Installation logging level
logging --level=info
# Reboot after installation
reboot
# System timezone
timezone --isUtc America/New_York
# System bootloader configuration
bootloader --location=mbr
autopart
# Partition clearing information
clearpart --all --initlabel

%packages --default --ignoremissing
%end
Comment 12 Chris Lumens 2011-02-22 14:38:42 EST
I think this should block the beta (or at least the final release) because it breaks the full interactivity of a kickstart install.
Comment 13 Chris Lumens 2011-02-28 15:36:33 EST
At the least, this should be fixed in anaconda-16.0.
Comment 14 Chris Lumens 2011-03-07 10:53:30 EST
*** Bug 682765 has been marked as a duplicate of this bug. ***
Comment 15 Chris Lumens 2011-03-07 10:54:42 EST
I'll pull this over for F15 too.
Comment 16 James Laska 2011-03-11 14:41:36 EST
Discussed at 2011-03-11 blocker review meeting.  This issue is fixed and available for testing in anaconda-15.21-1.  The issue has been accepted as a beta blocker.
Comment 17 Fedora Update System 2011-03-29 16:52:07 EDT
anaconda-15.26-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/anaconda-15.26-1.fc15
Comment 18 Fedora Update System 2011-03-29 22:25:38 EDT
Package anaconda-15.26-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-15.26-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/anaconda-15.26-1.fc15
then log in and leave karma (feedback).
Comment 19 He Rui 2011-03-30 00:14:54 EDT
Tested anaconda 15.25 of F15-beta, issue still happened.
Comment 20 James Laska 2011-03-30 09:01:51 EDT
(In reply to comment #19)
> Tested anaconda 15.25 of F15-beta, issue still happened.

Hi Hurry, can you upload anaconda.log for this issue?
Comment 21 He Rui 2011-03-31 02:13:04 EDT
Created attachment 488984 [details]
anaconda-logs.tar.gz
Comment 22 Tim Flink 2011-04-01 14:20:14 EDT
Discussed in the 2011-04-01 blocker review meeting. clumens will be look at this and try to fix.
Comment 23 James Laska 2011-04-04 16:08:46 EDT
I just tested anaconda-15.25-1 (F-15-Beta-TC1) using a kickstart that includes the 'reboot' command.  The kickstart was delivered via http (ks=http://server/path/to/ks.cfg ).  The installer does appear like it is rebooting, however it doesn't boot back up.  It only shuts down.

unmounting filesystems...
        /dev/pts done
        /selinux done
        /mnt/sysimage/boot done
        /mnt/sysimage/dev/pts done
        /mnt/sysimage/dev/shm done
        /mnt/sysimage/dev done
        /mnt/sysimage/proc/bus/usb done
        /mnt/sysimage/proc done
        /mnt/sysimage/selinux done
        /mnt/sysimage/sys done
        /mnt/sysimage done
waiting for mdraid sets to become clean...
sending termination signals...done
sending kill signals...done
rebooting system
[  426.833572] Restarting system.

This was tested in a KVM guest on a F14 KVM host.  On the same host, I confirmed that this is same behavior happens with a F-14 guest on my F-14 host.  I'm not seeing any further problems here, it looks like it's behaving consistent with previous releases.  I'll test on bare metal shortly, I have a feeling the failure to "reboot" is specific to virtualization.

Hurry, can you confirm?  Am I missing/forgetting something?
Comment 24 Fedora Update System 2011-04-05 17:37:33 EDT
anaconda-15.26-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 25 He Rui 2011-04-06 01:41:28 EDT
(In reply to comment #23)
> I just tested anaconda-15.25-1 (F-15-Beta-TC1) using a kickstart that includes
> the 'reboot' command.  The kickstart was delivered via http
> (ks=http://server/path/to/ks.cfg ).  The installer does appear like it is
> rebooting, however it doesn't boot back up.  It only shuts down.
> 
> unmounting filesystems...
>         /dev/pts done
>         /selinux done
>         /mnt/sysimage/boot done
>         /mnt/sysimage/dev/pts done
>         /mnt/sysimage/dev/shm done
>         /mnt/sysimage/dev done
>         /mnt/sysimage/proc/bus/usb done
>         /mnt/sysimage/proc done
>         /mnt/sysimage/selinux done
>         /mnt/sysimage/sys done
>         /mnt/sysimage done
> waiting for mdraid sets to become clean...
> sending termination signals...done
> sending kill signals...done
> rebooting system
> [  426.833572] Restarting system.
> This was tested in a KVM guest on a F14 KVM host.

I can always reproduce it.

>  On the same host, I
> confirmed that this is same behavior happens with a F-14 guest on my F-14 host.

Do you mean it also happens when virt-installing F-14 guest on F-14 host? I can't reproduce it. 

>  I'm not seeing any further problems here, it looks like it's behaving
> consistent with previous releases.  I'll test on bare metal shortly, I have a
> feeling the failure to "reboot" is specific to virtualization.
> Hurry, can you confirm?  Am I missing/forgetting something?

I used to test anaconda-15.25-1 (F-15-Beta-TC1) using a kickstart that doesn't include the 'reboot' command. After the kickstart auto-install, I manually clicked 'reboot', but after that it halted like:

 Running halt...
 disabling swap...
         /dev/sda3
 unmounting filesystems...
         /dev/pts done
         /mnt/source done
         /selinux done
         /mnt/sysimage/boot done
         /mnt/sysimage/dev/pts done
         /mnt/sysimage/dev/shm done
         /mnt/sysimage/dev done
         /mnt/sysimage/proc/bus/usb done
         /mnt/sysimage/proc done
         /mnt/sysimage/selinux done
         /mnt/sysimage/sys done
         /mnt/sysimage done
 waiting for mdraid sets to become clean...
 sending termination signals...done
 sending kill signals...done
 halting system
 [  426.833572] System halted.

For me, this issue happens when I use kickstart to install F-15 both in kvm and bare metal.
Comment 26 He Rui 2011-04-06 03:08:36 EDT
(In reply to comment #24)
> anaconda-15.26-1.fc15 has been pushed to the Fedora 15 stable repository.  If
> problems still persist, please make note of it in this bug report.

I tested it and found that if the kickstart includes the 'reboot' command, anaconda can reboot as expected after installation. But if ks doesn't include 'reboot', anaconda still halts after manually clicking 'reboot' button. Reopen the bug.
Comment 27 James Laska 2011-04-06 08:12:47 EDT
(In reply to comment #26)
> (In reply to comment #24)
> > anaconda-15.26-1.fc15 has been pushed to the Fedora 15 stable repository.  If
> > problems still persist, please make note of it in this bug report.
> 
> I tested it and found that if the kickstart includes the 'reboot' command,
> anaconda can reboot as expected after installation. But if ks doesn't include
> 'reboot', anaconda still halts after manually clicking 'reboot' button. Reopen
> the bug.

Thanks for the quick feedback Hurry, and good testing.  I've also confirmed that doing a Kickstart install without 'reboot', and then clicking the Reboot button ... indeed halts the system (instead of rebooting it).

I hesitate to file this as a new bug, since the current behavior is slightly different from the reported issue.  I'll defer to how clumens would like to handle the issue.

Also, based on your testing, I think the original use case is now sufficiently handled to cover the Beta release criteria.  If a user includes 'reboot' in their kickstart, the installation will be unattended as expected and reboot properly into the installed system.  My sense is that the new behavior you discovered no longer impacts the unattended install beta release criteria. [1]

 " Any installation method or process designed to run unattended must do so (there should be no prompts requiring user intervention) "

I recommend we move this to F-15-Beta Nice-to-have, and/or file a new bug to track the remaining problem.

[1] https://fedoraproject.org/wiki/Fedora_15_Beta_Release_Criteria
Comment 28 Chris Lumens 2011-04-06 10:54:49 EDT
I'm going to take the lame way out on this bug.  Given that we've met the release criteria (per comment #27) and are pretty far into edge case territory (comment #26), I say we close this for F15.  For post-F15, I am actively working on getting rid of our own init and replacing it with systemd.  As part of that, I'm drastically simplifying the process management and rebooting code.  Hopefully, I'll have this fixed there.  I'll make sure to put this case on the list of things to check.
Comment 29 Chris Lumens 2011-04-11 15:07:58 EDT
*** Bug 695445 has been marked as a duplicate of this bug. ***
Comment 30 Patrick C. F. Ernzer 2011-04-20 08:45:48 EDT
(In reply to comment #27)
[...]
> I've also confirmed
> that doing a Kickstart install without 'reboot', and then clicking the Reboot
> button ... indeed halts the system (instead of rebooting it).
[...]

I can confirm this behaviour in F15 Beta. While not ideal, I can live with it, provided it gets fixed in F16 and does not bite me in RHEL7 once that materialises. (I control the kickstart files, so adding reboot statement is easy, even though for some tests I prefer to have the system actually not reboot immediately after install)

Chris; what about tracking this for F16, do you want a cloned bug of this or shall this one be re-opened and assigned to release F16?
Comment 31 Patrick C. F. Ernzer 2011-10-05 12:17:06 EDT
I no longer see this bug in F16 Beta.
If I have 'reboot' in the ks file the system reboots as expected. If I do not have 'reboot' in the ks file then it reboots just fine after clicking OK in the final dialog box anaconda shows.
Thanks for the fix.

Note You need to log in before you can comment on or make changes to this bug.