Bug 676973 - fedpkg gives confusing error if rpm-build not installed
Summary: fedpkg gives confusing error if rpm-build not installed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-packager
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-12 07:07 UTC by Jens Petersen
Modified: 2017-04-09 06:45 UTC (History)
4 users (show)

Fixed In Version: fedora-packager-0.5.6.0-1.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-07 20:57:10 UTC


Attachments (Terms of Use)

Description Jens Petersen 2011-02-12 07:07:51 UTC
Description of problem:
fedpkg gets confused when rpm-build is not installed.

Version-Release number of selected component (if applicable):
fedora-packager-0.5.5.0-2.fc15

Steps to Reproduce:
1. make sure rpm-build is not installed
2. try to run "fedpkg local" in a pkg clone
  
Actual results:
rpm: /path/to/package.spec: No such file or directory
Could not build locally: Could not parse the spec, exited 1

Expected results:
Warning that rpm-build is missing.
(Not sure why rpm-build is needed to parse the spec file?:)

Additional info:
I dunno if fedpkg should require rpm-build,
though it is not needed for fedpkg clone for example.

Comment 1 Jesse Keating 2011-02-14 18:09:36 UTC
Ah, we used to get rpm-build when fedpkg was a direct part of fedora-packager.  Now that it's a subpackage, which doesn't require fedora-packager, we lost that dep.  I've added it in upstream.

Comment 2 Fedora Update System 2011-02-23 20:07:16 UTC
fedora-packager-0.5.6.0-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/fedora-packager-0.5.6.0-1.fc14

Comment 3 Fedora Update System 2011-02-23 20:28:52 UTC
fedora-packager-0.5.6.0-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/fedora-packager-0.5.6.0-1.fc13

Comment 4 Fedora Update System 2011-02-23 20:30:36 UTC
fedora-packager-0.5.6.0-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/fedora-packager-0.5.6.0-1.el5

Comment 5 Fedora Update System 2011-02-23 21:51:33 UTC
fedora-packager-0.5.6.0-1.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fedora-packager'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/fedora-packager-0.5.6.0-1.el5

Comment 6 Fedora Update System 2011-03-03 21:58:37 UTC
Package fedora-packager-0.5.6.0-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 updates-testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fedora-packager-0.5.6.0-1.fc15'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/fedora-packager-0.5.6.0-1.fc15
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2011-03-07 20:56:50 UTC
fedora-packager-0.5.6.0-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2011-03-08 02:25:40 UTC
fedora-packager-0.5.6.0-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2011-03-08 20:26:41 UTC
fedora-packager-0.5.6.0-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2011-03-22 16:30:30 UTC
fedora-packager-0.5.6.0-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Saša Janiška 2017-04-09 06:45:11 UTC
Hello,

starting to learn about Fedora packaging and following the 

https://fedoraproject.org/wiki/How_to_create_an_RPM_package doc.

Trying with:

$ fedpkg --release f25 local
sources file doesn't exist. Source files download skipped.
rpm: /usr/bin/rpmspec: No such file or directory

Could not execute local: Could not get n-v-r-e from '\n'


so, on my up-to-date F25 system, the problem is still persising if rpm-build is not installed!

After installing rpm-build I get:

$  fedpkg --release f25 local
sources file doesn't exist. Source files download skipped.

Executing(%install): /bin/sh -e /var/tmp/rpm-tmp.hgv7rX
+ umask 022
+ cd /home/gour/prj/fedora/howdy
+ '[' /home/gour/rpmbuild/BUILDROOT/howdy-1-1.fc25.x86_64 '!=' / ']'
+ rm -rf /home/gour/rpmbuild/BUILDROOT/howdy-1-1.fc25.x86_64
++ dirname /home/gour/rpmbuild/BUILDROOT/howdy-1-1.fc25.x86_64
+ mkdir -p /home/gour/rpmbuild/BUILDROOT
+ mkdir /home/gour/rpmbuild/BUILDROOT/howdy-1-1.fc25.x86_64
+ /usr/lib/rpm/check-buildroot
+ /usr/lib/rpm/brp-compress
+ /usr/lib/rpm/brp-strip /usr/bin/strip
+ /usr/lib/rpm/brp-strip-comment-note /usr/bin/strip /usr/bin/objdump
+ /usr/lib/rpm/brp-strip-static-archive /usr/bin/strip
+ /usr/lib/rpm/brp-python-bytecompile /usr/bin/python 1
+ /usr/lib/rpm/brp-python-hardlink
+ /usr/lib/rpm/redhat/brp-java-repack-jars
Processing files: howdy-1-1.fc25.x86_64
Checking for unpackaged file(s): /usr/lib/rpm/check-files /home/gour/rpmbuild/BUILDROOT/howdy-1-1.fc25.x86_64
Wrote: /home/gour/prj/fedora/howdy/howdy-1-1.fc25.src.rpm
Wrote: /home/gour/prj/fedora/howdy/x86_64/howdy-1-1.fc25.x86_64.rpm
Executing(%clean): /bin/sh -e /var/tmp/rpm-tmp.ciGcCx
+ umask 022
+ cd /home/gour/prj/fedora/howdy
+ /usr/bin/rm -rf /home/gour/rpmbuild/BUILDROOT/howdy-1-1.fc25.x86_64
+ exit 0


so it would be nice to fix the toolchain to install rpm-build via some dependency.


Note You need to log in before you can comment on or make changes to this bug.