Bug 67707 - after upgrade to 2.4.18-5, tulip won't load
Summary: after upgrade to 2.4.18-5, tulip won't load
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i586 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Garzik
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-30 06:10 UTC by Douglas Campbell
Modified: 2013-07-03 02:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-05 20:05:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Douglas Campbell 2002-06-30 06:10:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:0.9.4.1)
Gecko/20020508 Netscape6/6.2.3

Description of problem:
After upgrading to 2.4.18-5, using rpm -Fvh, rebooted from previous correctly
operating 2.4.18-3 (base RH Linux 7.3) system.  System refused to load tulip
device. 
 
modprobe tulip indicates desire to access /lib/modules/2.4.18-3/modules.dep
(which does not exist after upgrade)
All files exist under /lib/modules/2.4.18-5/... and have dates "Jun 10 12:26" or
thereabouts.  Under /boot, the binary file "map" continues to reference
2.4.18-3, but all other references have been updated to 2.4.18-5.

Attempted to repair - built softlink 2.4.18-3 -> 2.4.18-5 under /lib/modules and
reperformed modprobe tulip; tulip then claims many missing kernel symbols (e.g.,
pci_write_config_dword_R57e8add4), followed by insmod failure.  A reboot does
not fix the problem.

Version-Release number of selected component (if applicable):
2.4.18-5

How reproducible:
Didn't try

Steps to Reproduce:
1. Install vanilla redhat7.3 on i586 system with tulip NIC.
2. Install i586 versions of kernel patches to upgrade kernel from 2.4.18-3 to
2.4.18-5
3. reboot
	

Additional info:

Two bugs appear to be present.  I don't think modprobe should be asking for
2.4.18-3 stuff after the upgrade.  The version of tulip provided doesn't appear
to match the kernel.  I have sources and will try to rebuild.

Comment 1 Douglas Campbell 2002-06-30 22:45:44 UTC
Reran install and performed upgrade; selected smp kernel.  Install updated only
the kernel.  After reboot, system is again operational and tulip device operational.

Comment 2 Jeff Garzik 2003-08-05 20:05:34 UTC
Since reporter indicated bug disappeared for him, closing with 'worksforme'.



Note You need to log in before you can comment on or make changes to this bug.