Bug 67710 - https://xmlrpc.rhn.redhat.com displays default Apache test page
https://xmlrpc.rhn.redhat.com displays default Apache test page
Status: CLOSED NOTABUG
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
RHN Stable
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Turner
Fanny Augustin
https://xmlrpc.rhn.redhat.com/
:
Depends On:
Blocks: 76982
  Show dependency treegraph
 
Reported: 2002-06-30 09:39 EDT by Kiat Huang
Modified: 2007-04-18 12:43 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-18 19:54:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kiat Huang 2002-06-30 09:39:04 EDT
How Reproducible:


Steps to Reproduce:
1. Go to https://xmlrpc.rhn.redhat.com/
2. Either from an internal redhat.com ip or from my external domain:
huang.dyndns.org

Actual Results:
The default Apache test page is served.

Expected Results:
Redirect to RHN site


Additional Information:
Comment 1 Josef Komenda 2002-07-02 16:58:39 EDT
Chip, is this even a bug? Why would someone browse to this page?
Comment 2 Mihai Ibanescu 2002-10-31 17:21:28 EST
They wouldn't normally, but it looks really bad. Additionally, it displays an
SSL mismatch between the host's name and the Common Name.

Chip, can we redirect / to rhn.redhat.com? Or we did this before and we confused
the load balancer?
Comment 3 Todd Warner 2002-12-09 15:18:33 EST
It's been a couple months... status?
Comment 4 Cristian Gafton 2003-02-18 19:54:34 EST
That is by design. We need to have a real page there for the CSS to work
correctly. We can not redirect. No normal website traffic should be done on
xmlrpc.rhn.redhat.com - if you point a browser to it you get to keep all the
broken bits.

NOTABUG
Comment 5 Chip Turner 2003-02-18 21:32:18 EST
if you hit it now, you get a simple page that says 'Red Hat Network' -- at
least, that's what I get.  can anyone confirm the problem is 'fixed' (not
blatantly wrong) anymore?
Comment 6 Josef Komenda 2003-02-19 10:06:58 EST
Mo' betta. 

Note You need to log in before you can comment on or make changes to this bug.