Bug 677131 - How to skip update disk prompt
How to skip update disk prompt
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
AcceptedNTH https://fedoraproject.org...
: CommonBugs
: 682582 (view as bug list)
Depends On:
Blocks: 494832 F15Alpha-accepted/F15AlphaFreezeExcept F15Beta/F15BetaBlocker
  Show dependency treegraph
 
Reported: 2011-02-13 10:43 EST by Orion Poplawski
Modified: 2011-04-20 10:20 EDT (History)
8 users (show)

See Also:
Fixed In Version: anaconda-15.26-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-05 17:39:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
kickstart file (12.34 KB, text/plain)
2011-02-14 10:55 EST, Orion Poplawski
no flags Details
anaconda.log (10.67 KB, text/plain)
2011-02-14 10:56 EST, Orion Poplawski
no flags Details

  None (edit)
Description Orion Poplawski 2011-02-13 10:43:35 EST
Description of problem:

Trying to do a text mode ks install of F15 Alpha TC1 and I get a prompt for update disk source.  For unattended installs we can't have any prompts.  Is a new ks option needed?  If so, a release note will be warranted.

Version-Release number of selected component (if applicable):
15.19
Comment 1 Chris Lumens 2011-02-13 18:42:03 EST
Please attach your kickstart file and /tmp/anaconda.log.  Thanks.
Comment 2 Orion Poplawski 2011-02-14 10:55:46 EST
Created attachment 478657 [details]
kickstart file
Comment 3 Orion Poplawski 2011-02-14 10:56:46 EST
Created attachment 478658 [details]
anaconda.log
Comment 4 Chris Lumens 2011-02-14 13:24:45 EST
Hm, those weren't as enlightening as I'd hoped.  Do you remember the exact message of the dialog you're hitting?
Comment 5 Orion Poplawski 2011-02-14 18:17:13 EST
Title: Update Disk Source

You have multiple devices which could serve as sources for an update disk.  Which would you like to use?

sr0
vda

Ok Cancel
Comment 6 Chris Lumens 2011-02-14 18:29:38 EST
Okay, I think I see what's going on now.  Thanks.
Comment 7 Chris Lumens 2011-02-15 10:10:23 EST
Proposing as a blocker, as this makes automated installs no longer automated.  This should hit just about everyone doing a kickstart install.
Comment 8 James Laska 2011-02-15 10:14:25 EST
I don't think we have criteria would be impacted by fully automated installs.  We'll need to work on that.  In the meantime, this would *definitely* qualify as a nice to have for the Alpha in my opinion.

https://fedoraproject.org/wiki/QA/ReleaseCriteria
Comment 9 Adam Williamson 2011-02-18 12:25:56 EST
we are working on criteria for kickstart installs, remember, jlaska. i think the email ball is in your court atm =)
Comment 10 Robyn Bergeron 2011-02-18 12:28:22 EST
Per 2011-02-18 alpha blocker meeting:

#agreed 677131 - Accepted as Alpha NTH, rejected as Alpha blocker.
Comment 11 James Laska 2011-02-18 15:38:14 EST
(In reply to comment #9)
> we are working on criteria for kickstart installs, remember, jlaska. i think
> the email ball is in your court atm =)

I haven't settled on anything concrete from our private discussion on this, but it's still in my inbox awaiting inspiration.
Comment 12 Sandro Mathys 2011-03-02 07:14:23 EST
Can reproduce with Alpha RC2 - please reconsider this bug as a blocker for beta, even if there's no criteria for this case yet. Required interactions in non-interactive installations are a really bad thing.
Comment 13 Chris Lumens 2011-03-02 10:21:59 EST
It's already been committed to the f15-branch for beta, hence the Fixed In Version: starts with a "15" instead of a "16".
Comment 14 Ales Kozumplik 2011-03-07 02:19:38 EST
*** Bug 682582 has been marked as a duplicate of this bug. ***
Comment 15 James Laska 2011-03-11 14:41:39 EST
Discussed at 2011-03-11 blocker review meeting.  This issue is fixed and available for testing in anaconda-15.21-1.  The issue has been accepted as a beta blocker.
Comment 16 James Laska 2011-03-25 11:09:19 EDT
VERIFIED, I'm not seeing this in anaconda-15.24-1 images.
Comment 17 Fedora Update System 2011-03-29 16:59:15 EDT
anaconda-15.26-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/anaconda-15.26-1.fc15
Comment 18 Fedora Update System 2011-03-29 22:26:09 EDT
Package anaconda-15.26-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-15.26-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/anaconda-15.26-1.fc15
then log in and leave karma (feedback).
Comment 19 James Laska 2011-03-30 09:13:08 EDT
Confirmed with F-15-Beta-TC1
Comment 20 Fedora Update System 2011-04-05 17:38:03 EDT
anaconda-15.26-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 Patrick C. F. Ernzer 2011-04-20 10:20:48 EDT
Confirmed fixed in F15 Beta
Thanks!

Note You need to log in before you can comment on or make changes to this bug.