Bug 677153 - gcc driver does not pass needed libraries for libgcc_eh.a on collect2 command line
Summary: gcc driver does not pass needed libraries for libgcc_eh.a on collect2 command...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mingw32-gcc
Version: rawhide
Hardware: All
OS: All
unspecified
medium
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-13 18:23 UTC by Thomas Sailer
Modified: 2011-06-21 09:44 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-21 09:44:27 UTC


Attachments (Terms of Use)

Description Thomas Sailer 2011-02-13 18:23:43 UTC
Description of problem:
libgcc_eh.a sometimes needs symbols from libmingw32.a (___mingwthr_key_dtor) and libkernel32.a (_SetLastError@4, _InterlockedIncrement@4, _TlsAlloc@0, _TlsSetValue@8), but does not pass -lmingw32 -lkernel32 to collect2 after -lgcc_eh. The result is that, when compiling glib2-2.28.0, linking 
glib-compile-schemas.exe fails; I had to manually call collect2 with added arguments to make the mingw32-glib2 rpm build.

Version-Release number of selected component (if applicable):
mingw32-gcc-4.5.1-2.fc15

How reproducible:
always

Steps to Reproduce:
see for example the mingw32-glib2-2.28.0-1.fc16.src.rpm and remove the two lines marked with "evil hack".
  
Actual results:
Missing symbols during linking of gio/glib-compile-schemas.exe

Expected results:
Linking succeeds

Comment 1 Erik van Pienbroek 2011-02-13 20:32:38 UTC
Isn't this a side-effect of mingw32-runtime 3.18 being re-added to the repositories caused by the mass rebuild? In bug 629209 there was a comment that the mingw32-runtime 3.18 package was pulled from the buildroot because of issues: https://bugzilla.redhat.com/show_bug.cgi?id=629209#c19

As far as I know that package shouldn't have been re-added to the F15/F16 repositories..

Comment 2 Kalev Lember 2011-06-21 09:44:27 UTC
I believe the bug in mingw32-runtime is fixed: http://pkgs.fedoraproject.org/gitweb/?p=mingw32-runtime.git;a=commitdiff;h=ae21a9a8853

Closing the ticket.


Note You need to log in before you can comment on or make changes to this bug.