Bug 67726 - Wrong working with multipart/form-data
Summary: Wrong working with multipart/form-data
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: php   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Phil Copeland
QA Contact: David Lawrence
URL: http://www.satelit.cz/
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-01 05:45 UTC by Need Real Name
Modified: 2007-04-18 16:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-11 14:16:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-07-01 05:45:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:
When I tryed to use ecntype="multipart/form-data" all transeferd data was lost 
during transfer.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
<form method="POST" action="upload.php" enctype="multipart/form-data">
<input type="text" name="nazev" size="50" maxlength="50">
</form>	

<?PHP
echo $nazev;
?>


Additional info:

Comment 1 Eric Doutreleau 2002-07-11 12:06:07 UTC
I had the same problem
I solved it by changing the following parameter in /etc/php/ini
file_uploads = Off
to
file_uploads = On

Hope this help

Comment 2 Eric Doutreleau 2002-07-11 14:16:19 UTC
opps it was /etc/php.ini and not /etc/php/ini

Comment 3 Phil Copeland 2002-08-05 20:31:43 UTC
The default from a security standpoint is to leave this option off and leave it
up to the administrator of the server to enable it if they choose.
Really it's a pick a choose option.

You have to understand that when php is installed that you MUST look through the
php.ini file settings to ensure they are correct for your setup.

Since a few people complained I'm going to leave it enabled in future versions.
This is not a bug

Phil
=--=


Note You need to log in before you can comment on or make changes to this bug.