Bug 677272 - smbldaptools script configure.pl aborted due to compilation errors
Summary: smbldaptools script configure.pl aborted due to compilation errors
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: smbldap-tools
Version: el5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Paul Howarth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-14 09:06 UTC by Bruno Fey
Modified: 2011-03-23 20:25 UTC (History)
1 user (show)

Fixed In Version: smbldap-tools-0.9.6-3.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-12 04:44:25 UTC


Attachments (Terms of Use)

Description Bruno Fey 2011-02-14 09:06:26 UTC
Description of problem:

if i run perl configure.pl 

  Use of $# is deprecated at configure.pl-org line 313.
  Number found where operator expected at configure.pl-org line 527, near "#   
  Allows not to use smbpasswd (if with_smbpasswd="0"
  (Might be a runaway multi-line "" string starting on line 313)
  (Missing operator before 0?)
  String found where operator expected at configure.pl-org line 532, near "# 
  Allows not to use slappasswd (if with_slappasswd=""
  (Might be a runaway multi-line "" string starting on line 527)
  (Missing semicolon on previous line?)
   Number found where operator expected at configure.pl-org line 532, near "# 
   Allows not to use slappasswd (if with_slappasswd="0"
  (Missing operator before 0?)
   String found where operator expected at configure.pl-org line 539, near """
  (Might be a runaway multi-line "" string starting on line 532)
  (Missing semicolon on previous line?)
   syntax error at configure.pl-org line 527, near "# Allows not to use 
   smbpasswd (if with_smbpasswd="0"
   Execution of configure.pl-org aborted due to compilation errors.


Version-Release number of selected component (if applicable):
  Name        : smbldap-tools
  Version     : 0.9.6        
  Release     : 1.el5       
  Source RPM  : smbldap-tools-0.9.6-1.el5.src.rpm


How reproducible:
  run perl configure.pl

Steps to Reproduce:
1. perl configure.pl
2.
3.
  
Actual results:


Expected results:


Additional info:
you can solve the problem:
at line 527
  +# Allows not to use smbpasswd (if with_smbpasswd== 0 in smbldap.conf) but
  -# Allows not to use smbpasswd (if with_smbpasswd="0" in smbldap.conf) but
 
at line 532 
  +# Allows not to use smbpasswd (if with_smbpasswd== 0 in smbldap.conf) but
  -# Allows not to use smbpasswd (if with_smbpasswd="0" in smbldap.conf) but

Comment 1 Fedora Update System 2011-03-07 20:05:14 UTC
smbldap-tools-0.9.6-3.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/smbldap-tools-0.9.6-3.fc13

Comment 2 Fedora Update System 2011-03-07 20:05:24 UTC
smbldap-tools-0.9.6-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/smbldap-tools-0.9.6-3.fc14

Comment 3 Fedora Update System 2011-03-07 20:05:35 UTC
smbldap-tools-0.9.6-3.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/smbldap-tools-0.9.6-3.el5

Comment 4 Fedora Update System 2011-03-07 20:05:46 UTC
smbldap-tools-0.9.6-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/smbldap-tools-0.9.6-3.fc15

Comment 5 Fedora Update System 2011-03-07 20:05:59 UTC
smbldap-tools-0.9.6-3.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/smbldap-tools-0.9.6-3.el6

Comment 6 Fedora Update System 2011-03-07 20:06:09 UTC
smbldap-tools-0.9.6-3.el4 has been submitted as an update for Fedora EPEL 4.
https://admin.fedoraproject.org/updates/smbldap-tools-0.9.6-3.el4

Comment 7 Fedora Update System 2011-03-08 02:17:33 UTC
smbldap-tools-0.9.6-3.fc15 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update smbldap-tools'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/smbldap-tools-0.9.6-3.fc15

Comment 8 Fedora Update System 2011-03-12 04:44:20 UTC
smbldap-tools-0.9.6-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2011-03-16 19:52:06 UTC
smbldap-tools-0.9.6-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2011-03-16 19:53:11 UTC
smbldap-tools-0.9.6-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2011-03-23 20:24:49 UTC
smbldap-tools-0.9.6-3.el4 has been pushed to the Fedora EPEL 4 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2011-03-23 20:25:06 UTC
smbldap-tools-0.9.6-3.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2011-03-23 20:25:19 UTC
smbldap-tools-0.9.6-3.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.