Bug 677353 - initrd.img broken after preupgrade and /boot too small for install.img
initrd.img broken after preupgrade and /boot too small for install.img
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
12
i386 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-14 08:30 EST by Albert Flügel
Modified: 2012-02-02 04:25 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-02 04:25:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Albert Flügel 2011-02-14 08:30:45 EST
Description of problem:
Tried to upgrade from FC12 + latest patches to FC14. While running preupgrade i got the warning, that /boot is too small for the stage2 install.img, but this could be fetched later automatically over network. Fine for me, so i pressed Continue. preupgrade added an entry to grub.conf pointing stage2 to the proper URL. Then i booted into this entry and immediately the system hung without any message. Examining the problem showed, that the initrd.img was incomplete (about 55% of the size it should have). Something must have happened during download. Either the /boot filesystem got full due to parallel activities (probably trying to download install.img ?) or the download got interrupted somehow. Anyway imo there should be a check afterwards, whether vmlinuz and initrd.img have been downloaded correctly e.g. by checksumming.

Version-Release number of selected component (if applicable):
preupgrade-1.1.8-1.fc12.1.noarch.rpm

How reproducible:


Steps to Reproduce:
1. Install FC12 with latest patches with a 200 MB /boot filesystem
2. Run preupgrade
3. press continue when prompted, that /boot is too small for install.img
4. boot into the installer
  
Actual results:
System hangs immediately forever without any message

Expected results:
System boots, downloads the stage2 image and starts the installer (like with the  sane initrd.img)

Additional info:
see above.

Note You need to log in before you can comment on or make changes to this bug.