Bug 677365 - [RFE] Include compiz-fusion
[RFE] Include compiz-fusion
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: compiz (Show other bugs)
6.0
All Linux
low Severity low
: rc
: ---
Assigned To: Owen Taylor
Desktop QE
: FutureFeature, Triaged
Depends On:
Blocks: 607248 840699
  Show dependency treegraph
 
Reported: 2011-02-14 09:04 EST by J.H.M. Dassen (Ray)
Modified: 2013-07-03 00:10 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-13 14:37:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Legacy) 46261 None None None Never

  None (edit)
Description J.H.M. Dassen (Ray) 2011-02-14 09:04:32 EST
What is the nature and description of the request?
Customer want following compiz packages to be included in RHEL-6 minor release:

compiz-fusion
compiz-manager
compizconfig-python
libcompizconfig
compizconfig-backend-gconf
compiz-fusion-gnome
compiz-fusion-extras
compiz-fusion-extras-gnome

Why does the customer need this? (List the business requirements here)
Customer would like to manage multiple applications windows opened on Desktop
which is found very easy by using compiz effects as per following information
provided by customer:

Scale - just like Apple's Expose feature on Mac. I can look at all the windows
on a VD to quickly find the right one, or I can look at all th windows on all
VDs to quickly find the right one

Expo - shows me a scaled down version of all VDs at once, so that I can see
what is going on in each one and pick the right VD for what I want to do

Window Previews - allow previewing what the window is when mousing over icons
in the taskbar

Shelf - visually scale down a window to allow easy monitoring of that window
w/o taking up lots of desktop real estate

How would the customer like to achieve this? (List the functional requirements
here)
By installing listed compiz packages in requirement section. 

For each functional requirement listed in question 4, specify how Red Hat and
the customer can test to confirm the requirement is successfully implemented.
By installing and successful testing of compiz* packages for RHEL-6. 
 
Is there already an existing RFE upstream or in Red Hat bugzilla?
Not found. 

How quickly does this need resolved? (desired target release)
RHEL-6.2
 
Does this request meet the RHEL Inclusion criteria (please review)
Yes. 

List the affected packages
compiz-fusion
compiz-manager
compizconfig-python
libcompizconfig
compizconfig-backend-gconf
compiz-fusion-gnome
compiz-fusion-extras
compiz-fusion-extras-gnome
Comment 2 leigh scott 2011-04-01 11:31:57 EDT
I'm willing to package these for EPEL6, I already co-maintain these packages for fedora.
Comment 3 RHEL Product and Program Management 2011-07-05 20:16:15 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 5 Brian Gollaher 2011-12-10 16:24:57 EST
Thank you for submitting this feature request for inclusion in Red Hat Enterprise Linux. Your request will be considered in a future release of Red Hat Enterprise Linux.
Comment 7 RHEL Product and Program Management 2012-07-10 01:54:47 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 8 RHEL Product and Program Management 2012-07-10 19:09:44 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 9 Brian Gollaher 2012-07-13 14:37:10 EDT
Many of these features will be available in RHEL 7 when we incorporate the Gnome3 desktop.

Note You need to log in before you can comment on or make changes to this bug.