Bug 677367 - Remove hal dependency
Remove hal dependency
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: matahari (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Arjun Roy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-14 09:12 EST by Nicola Soranzo
Modified: 2011-04-27 11:01 EDT (History)
6 users (show)

See Also:
Fixed In Version: matahari-0.4.1-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-27 11:01:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicola Soranzo 2011-02-14 09:12:48 EST
Description of problem:
In both the Fedora and upstream spec files, matahari requires hal and build-requires hal-devel, but there is no other mention of hal in the latest sources from git.
Since HAL has been deprecated for 2 years, Fedora is trying to remove it from the distribution:

https://fedoraproject.org/wiki/Features/HalRemoval

I tried to remove the lines:

Requires:	hal

and

BuildRequires:  hal-devel

from matahari.spec and the package builds correctly, but I am not able to test it.

Version-Release number of selected component (if applicable):
matahari-0.4.0-0.1.8003b6c.git.fc15.1
Comment 1 Nicola Soranzo 2011-04-21 10:40:29 EDT
Please note that the hal package has been deprecated and blocked from composes for rawhide.

Therefore, there are some broken dependencies for your package now:

matahari-0.4.0-0.1.8003b6c.git.fc15.1.i686 requires hal

Note You need to log in before you can comment on or make changes to this bug.