Bug 67738 - User unable to chose soundcard to configure when multiple exist
User unable to chose soundcard to configure when multiple exist
Status: CLOSED DUPLICATE of bug 30677
Product: Red Hat Linux
Classification: Retired
Component: sndconfig (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-01 07:53 EDT by Erik Sxe Sxrensen
Modified: 2014-03-16 22:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-01 07:53:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erik Sxe Sxrensen 2002-07-01 07:53:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
When multiple sound cards exist in a machine, the user is never asked which one
is to be configured.
This is especially a problem when there is an on-board soundcard. I have,
although I was not aware of it until sndconfig would not let me configure my SB
card.
(I don't know whether to call this a bug or a missing feature)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Have more than one sound card installed (eg., an on-board and a PCI card)
2. Run sndconfig

	

Actual Results:  The auto-detected sound card seems to be the one listed first
in the output from lspci.

When the 'correct' sound card is already configured correctly, the test sound is
played OK, but not through the sound card that sndconfig claims to have
autodetected, but through the one already configured.
When writing that auto-detected configuration, it does not prove to be wrong
until after reboot (which is of course too confusing to be good).

Additional info:

# lspci |grep -i audio
00:05.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
00:0a.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 07)
Comment 1 Bill Nottingham 2002-07-22 19:09:18 EDT

*** This bug has been marked as a duplicate of 30677 ***

Note You need to log in before you can comment on or make changes to this bug.