Bug 677418 - qt-devel should require qt-sqlite
qt-devel should require qt-sqlite
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-14 12:41 EST by Orion Poplawski
Modified: 2011-03-02 21:50 EST (History)
10 users (show)

See Also:
Fixed In Version: qt-4.7.1-17.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-25 22:56:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2011-02-14 12:41:32 EST
Description of problem:

Without qt-sqlite present, qhelpgenerator can error with:

[  6%] Compiling Qt help project paraview.qhp
cd /builddir/build/BUILD/ParaView-3.10.0-RC1/fedora/Documentation && /usr/bin/qhelpgenerator /builddir/build/BUILD/ParaView-3.10.0-RC1/fedora/Documentation/paraview.qhp -o /builddir/build/BUILD/ParaView-3.10.0-RC1/fedora/Documentation/paraview.qch
QSqlDatabase: QSQLITE driver not loaded
QSqlDatabase: available drivers: 
Cannot open data base file /builddir/build/BUILD/ParaView-3.10.0-RC1/fedora/Documentation/paraview.qch!
Building up file structure...
make[2]: Leaving directory `/builddir/build/BUILD/ParaView-3.10.0-RC1/fedora'
make[2]: *** [Documentation/paraview.qch] Error 255

Version-Release number of selected component (if applicable):
4.7.1-15.fc15
Comment 1 Rex Dieter 2011-02-14 12:53:55 EST
sqlite seems pervasive, I'm tempted just to nuke the qt-sqlite, subpkg, and stuff it into (main) qt .  comments, objections?

Or just be minimal, and add the dep
Comment 2 Kevin Kofler 2011-02-14 12:58:06 EST
This is a regression due to the Assistant split. (Before, qt-devel dragged in qt-x11 which dragged in qt-sqlite for assistant to work.) It also affects the F14 update in testing and is a regression compared to F14 stable updates, so I'm adding the Regression flag.
Comment 3 Ngo Than 2011-02-15 10:07:44 EST
it's fine to move sqlite into main qt.
Comment 4 Fedora Update System 2011-02-15 16:01:18 EST
qt-4.7.1-16.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/qt-4.7.1-16.fc15
Comment 5 Fedora Update System 2011-02-15 16:41:55 EST
qt-4.7.1-16.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/qt-4.7.1-16.fc14
Comment 6 Fedora Update System 2011-02-15 20:30:12 EST
qt-4.7.1-16.fc15 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qt'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/qt-4.7.1-16.fc15
Comment 7 Bill Nottingham 2011-02-16 14:39:08 EST
Looking at the F-15 test update, it appears to not properly obsolete the prior qt-sqlite package.
Comment 8 Rex Dieter 2011-02-16 14:57:26 EST
yeah, I biffed that, upgrading from -15 is broken.  -17 should fix that.
Comment 9 Fedora Update System 2011-02-25 22:56:06 EST
qt-4.7.1-17.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2011-03-02 21:50:37 EST
qt-4.7.1-17.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.