Bug 677424 - St-ERROR **: st_widget_get_theme_node called on a widget not in a stage
St-ERROR **: st_widget_get_theme_node called on a widget not in a stage
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-14 13:21 EST by Lennart Poettering
Modified: 2013-07-01 20:30 EDT (History)
5 users (show)

See Also:
Fixed In Version: gnome-shell-3.8.3-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-01 20:30:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
c program that tiggers the crash in g-s. (3.29 KB, text/x-csrc)
2011-02-14 13:21 EST, Lennart Poettering
no flags Details

  None (edit)
Description Lennart Poettering 2011-02-14 13:21:36 EST
Created attachment 478682 [details]
c program that tiggers the crash in g-s.

attached you'll find a simple .c program I have been using since metacity times which orders all gnome-terminal windows in a 2x2 grid and moves them to deskop #2 assuring there are 6 desktops around. That worked fine in metacity, but in gnome-shell fails miserably in multiple ways:

- After login and starting at least one terminal from which I run this command gnome-shell will abort with "St-ERROR **: st_widget_get_theme_node called on a widget not in a stage"

- The number of desktops is not actually changed to 6

- After running it a second time g-s doesn't crash anymore and the number of desktops is increased to 6, but the terminals are not actually moved to desktop #2. 

- After running it a third time the windows are moved too.

I have seen the abort above in other contexts as well, so even if you do not use my little tool you run into this sooner or later, so consider my tool just as a good example to trigger this problem with.

This is gnome-shell-2.91.6-5.fc15.x86_64 (today's rawhide).
Comment 1 Fedora End Of Life 2013-04-03 12:36:42 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 19 development cycle.
Changing version to '19'.

(As we did not run this process for some time, it could affect also pre-Fedora 19 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 19 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora19
Comment 2 Fedora Update System 2013-06-26 04:22:48 EDT
gnome-shell-3.8.3-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gnome-shell-3.8.3-3.fc19
Comment 3 Fedora Update System 2013-06-26 13:07:14 EDT
Package gnome-shell-3.8.3-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-shell-3.8.3-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11708/gnome-shell-3.8.3-3.fc19
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-07-01 20:30:09 EDT
gnome-shell-3.8.3-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.