Bug 67743 - VIA KN133 and PN133 fails to auto-detect, missing driver name in hwdata
VIA KN133 and PN133 fails to auto-detect, missing driver name in hwdata
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
limbo
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-01 09:28 EDT by Warren Togami
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-14 19:03:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg from Compaq Presario 722US (7.05 KB, text/plain)
2002-07-01 09:31 EDT, Warren Togami
no flags Details
lspci -vv from Compaq Presario 722US (7.05 KB, text/plain)
2002-07-01 09:32 EDT, Warren Togami
no flags Details
lspci -vn (2.60 KB, text/plain)
2002-07-12 01:01 EDT, Warren Togami
no flags Details

  None (edit)
Description Warren Togami 2002-07-01 09:28:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1a+) Gecko/20020623

Description of problem:
In testing Red Hat Linux 7.3 on the Compaq Presario 700 series laptop, the video
chipset failed to be auto-detected by both the installer and Xconfigurator.

This laptop series has either Athlon Palomino or Duron Morgan CPU's with the VIA
KN133 chipset.  The KN133 chipset is basically the KT133A chipset with
integrated video identified as "S3 Graphics Twister K Compaq" in Windows.  After
digging through some VIA specs and other reports on linux-laptop.net, it seems
that the "S3 Savage4 Pro+" driver set to 16MB RAM works flawlessly in 2D (DRI 3D
is not available with this chipset.)

Do you need any more information to make auto-detect for this chipset to work?  
Perhaps also add to the PCI database?
Possible to auto-detect the monitor (generic 1024x768 laptop display) too?

Please let me know if you need any more information.  Attached are the full
lspci -vv and dmesg outputs.

lspci -vv for this device
-------------------------
01:00.0 VGA compatible controller: S3 Inc.: Unknown device 8d02 (rev 01)
(prog-if 00 [VGA])
        Subsystem: Compaq Computer Corporation: Unknown device 0086
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <P
ERR-
        Latency: 64 (1000ns min, 63750ns max), cache line size 08
        Interrupt: pin A routed to IRQ 5
        Region 0: Memory at e8100000 (32-bit, non-prefetchable) [size=512K]
        Region 1: Memory at f0000000 (32-bit, prefetchable) [size=128M]
        Expansion ROM at <unassigned> [disabled] [size=64K]
        Capabilities: [dc] Power Management version 2
                Flags: PMEClk- DSI+ D1+ D2+ AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [80] AGP version 2.0
                Status: RQ=31 SBA- 64bit- FW- Rate=<none>
                Command: RQ=0 SBA- AGP- 64bit- FW- Rate=<none>

Version-Release number of selected component (if applicable):
Red Hat Linux 7.3

How reproducible:
Always

Steps to Reproduce:
1. Attempt to setup X.
2. Fails to auto-detect video chipset.
Comment 1 Warren Togami 2002-07-01 09:31:34 EDT
Created attachment 63244 [details]
dmesg from Compaq Presario 722US
Comment 2 Warren Togami 2002-07-01 09:32:13 EDT
Created attachment 63245 [details]
lspci -vv from Compaq Presario 722US
Comment 3 Mike A. Harris 2002-07-10 09:20:13 EDT
Need lspci -vn
Comment 4 Warren Togami 2002-07-12 01:01:41 EDT
Created attachment 65064 [details]
lspci -vn
Comment 5 Warren Togami 2002-07-20 05:56:18 EDT
Also what can I do to probe the hardware in order to submit laptop monitor
autodetection info?
Comment 6 Mike A. Harris 2002-07-26 09:17:22 EDT
#define PCI_CHIP_SAVAGE3D       0x8A20
#define PCI_CHIP_SAVAGE3D_MV    0x8A21
#define PCI_CHIP_SAVAGE4        0x8A22
#define PCI_CHIP_SAVAGE2000     0x9102
#define PCI_CHIP_VIRGE_MX       0x8C01
#define PCI_CHIP_VIRGE_MXPLUS   0x8C01
#define PCI_CHIP_VIRGE_MXP      0x8C03
#define PCI_CHIP_PROSAVAGE_PM   0x8A25
#define PCI_CHIP_PROSAVAGE_KM   0x8A26
#define PCI_CHIP_SAVAGE_MX_MV   0x8c10
#define PCI_CHIP_SAVAGE_MX      0x8c11
#define PCI_CHIP_SAVAGE_IX_MV   0x8c12
#define PCI_CHIP_SAVAGE_IX      0x8c13

The above chips are what is supported in XFree86 current head CVS.
Your chip is not listed.  Hopefully a future XFree86 release will
support this chip.  In the mean time, I'll default this chip
to the 'vesa' driver.

Sorry I can't do anything else for this.  ;o/

Comment 7 Warren Togami 2002-07-26 13:24:53 EDT
Please, I think you misunderstood this report.  It only fails to auto-detect the
video chipset because it is not in the PCI ids, but if I manually select the S3
Savage4 Pro+ and 16MB VRAM it works flawlessly.
Comment 8 Warren Togami 2002-07-26 13:58:10 EDT
http://www.via.com.tw/en/ProSavage%20Chipsets/prosav_index.jsp

The VIA KN133 in this Compaq notebook has the same integrated graphics
controller as the KM133.
Comment 9 Warren Togami 2002-07-27 08:28:33 EDT
Within XFree86-4.2.0-55 and hwdata-0.33-1 are the following:

line 125 of savage_driver.c:
{ PCI_CHIP_S3TWISTER_K,     "ProSavage KN133" }

line 5750 of pci.ids:
        8d02  VT8636A [ProSavage KN133] AGP4X VGA Controller (TwisterK)

Thus it appears to be only missing this #define statement?
#define PCI_CHIP_PROSAVAGE_KN   0x8d02
Comment 10 Warren Togami 2002-07-27 08:41:19 EDT
Oops, I guess that would this instead
#define PCI_CHIP_S3TWISTER_K   0x8d02

If I am completely wrong on this one, please let me know.  I am trying my best
to learn and help out.
Comment 11 Warren Togami 2002-08-07 06:38:54 EDT
ops, I just found the following in savage_regs.h:

/* These are here until xf86PciInfo.h is updated. */

#ifndef PCI_CHIP_S3TWISTER_P
#define PCI_CHIP_S3TWISTER_P    0x8d01
#endif
#ifndef PCI_CHIP_S3TWISTER_K
#define PCI_CHIP_S3TWISTER_K    0x8d02
#endif

Does this mean that only "Card:S3 Savage4" is missing from hwdata's pcitable in
order to properly autodetect these cards?
Comment 12 Warren Togami 2002-08-07 13:31:45 EDT
https://listman.redhat.com/pipermail/limbo-list/2002-August/002141.html

pixel@mandrakesoft.com confirmed that "Card:S3 Savage 4" is the only thing that
is missing, preventing Red Hat's XFree86 from autodetecting these two video devices.
Comment 13 Warren Togami 2002-08-23 05:56:46 EDT
I take this back, sorry for the wasted time.  While this pcitable change worked
fine for the Compaq Presario 700, it failed on the HP ze1210.  I guess this
driver isn't yet entirely stable.

I have tested KM133, PM133, KN133 and PM133, and they all seem fine with Vesa,
so I guess this should be DEFERRED for now.
Comment 14 Mike A. Harris 2003-03-14 19:03:10 EST
All of these are supported in XFree86 4.3.0 currently.  I am considering
also backporting this to 4.2.1 and 4.1.0 sometime in the future, however
I wont promise anything for sure.

Closing as resolved in RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.