Bug 677457 - undefined symbols in libgtkglext-x11-1.0.so (GTK_WIDGET_NO_WINDOW etc)
undefined symbols in libgtkglext-x11-1.0.so (GTK_WIDGET_NO_WINDOW etc)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gtkglext (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ralf Corsepius
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-14 16:25 EST by John Ellson
Modified: 2011-06-29 10:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-29 10:35:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2011-02-14 16:25:19 EST
Description of problem:
Something in the mass rebuild updates broke gtkglext such that when building graphviz (upstream) I now get:

/usr/lib64/libgtkglext-x11-1.0.so: undefined reference to `GTK_WIDGET_REALIZED'
/usr/lib64/libgtkglext-x11-1.0.so: undefined reference to `GTK_WIDGET_TOPLEVEL'
/usr/lib64/libgtkglext-x11-1.0.so: undefined reference to `GTK_WIDGET_NO_WINDOW'

Version-Release number of selected component (if applicable):
gtkglext-libs-1.2.0-11.fc15.x86_64

How reproducible:
100%

Steps to Reproduce:
1. cd graphviz (from CVS)
2. ./configure
3. make
  
Actual results:
/usr/lib64/libgtkglext-x11-1.0.so: undefined reference to `GTK_WIDGET_REALIZED'
/usr/lib64/libgtkglext-x11-1.0.so: undefined reference to `GTK_WIDGET_TOPLEVEL'
/usr/lib64/libgtkglext-x11-1.0.so: undefined reference to `GTK_WIDGET_NO_WINDOW'

Expected results:
no errors (like two days ago and like on fc14 today)

Additional info:
Comment 1 John Ellson 2011-02-14 16:52:43 EST
Workaround:  downgrade to gtkglext-libs-1.2.0-10.fc12 and gtkglext-devel-1.2.0-10.fc12 from koji fixes the problem for the moment.
Comment 2 John Ellson 2011-02-15 09:39:10 EST
I notice that gtkglext's git repo already has a possible fix for this.  Perhaps it can be cherry-picked?

Author: Ionut Biru <biru.ionut@gmail.com>  2010-04-25 04:15:05
Committer: Braden McDaniel <braden@bolt.endoframe.net>  2010-04-25 04:15:05
Parent: b052c05f37d24383b7692b04dbabb1975a47bd33 (Update to 20100125 release of autoconf-gl-macros.  This addresses a)
Child:  b9b59224955786c00e888f5c5f86a447c3fd1954 (Update AX_CHECK_GL and AX_CHECK_GLU to the 2010-03-21 release.)
Branches: master, remotes/origin/master
Follows: 
Precedes: 

    Eliminate usage of GTK_WIDGET_REALIZED, GTK_WIDGET_TOPLEVEL, and GTK_WIDGET_NO_WINDOW for compatibility with Gtk+ >= 2.20.
Comment 3 Tadej Janež 2011-02-16 11:25:44 EST
I had the exact same problem when trying to recompile Techne. The build log is here:
https://koji.fedoraproject.org/koji/getfile?taskID=2839145&name=build.log

Please, fix this!
Comment 4 Ralf Corsepius 2011-02-16 13:27:56 EST
(In reply to comment #0)
> Something in the mass rebuild updates broke gtkglext such that when building
> graphviz (upstream) I now get:
Are you building upstream graphviz from sources? 
I tried rebuilding Fedora's graphviz, which builds flawlessly for me.

Seems as if Fedora >= 15's gtk has been disabled some deprecated functions.

(In reply to comment #2)
> I notice that gtkglext's git repo already has a possible fix for this.  Perhaps
> it can be cherry-picked?
That's what I'll try to do.

(In reply to comment #3)
> I had the exact same problem when trying to recompile Techne.
Thanks for the pointer ... unfortunately the package in Fedora's git doesn't build for other reasons.

Anyway, from what I can gather, seems as if Fedora >= 15's gtk has been disabled some deprecated functions.

I'll try to come up with an updated package tomorrow.
Comment 5 Fedora Update System 2011-02-16 13:46:14 EST
gtkglext-1.2.0-12.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gtkglext-1.2.0-12.fc15
Comment 6 Fedora Update System 2011-02-16 16:29:25 EST
gtkglext-1.2.0-12.fc15 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gtkglext'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/gtkglext-1.2.0-12.fc15
Comment 7 Fedora Update System 2011-02-16 22:56:13 EST
gtkglext-1.2.0-13.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gtkglext-1.2.0-13.fc15
Comment 8 Tadej Janež 2011-02-17 03:51:23 EST
(In reply to comment #4)
> Thanks for the pointer ... unfortunately the package in Fedora's git doesn't
> build for other reasons.

Yes, I was compiling a yet to be released version that fixes GCC 4.6 compile problems.

> 
> I'll try to come up with an updated package tomorrow.

I tried again today and it failed. From looking at the spec file, I think you forgot to apply the patch to the sources?

Thanks for fixing this!
Comment 9 Ralf Corsepius 2011-02-17 04:10:38 EST
(In reply to comment #8)

> > I'll try to come up with an updated package tomorrow.
> 
> I tried again today and it failed. From looking at the spec file, I think you
> forgot to apply the patch to the sources?

What are you looking at?

The "supposed to be fix" has been applied to git for rawhide and f15, only.

Corresponding packages have been built and are waiting to be pushed to the repos:
c.f. http://koji.fedoraproject.org/koji/packageinfo?packageID=1998

I haven't updated fc13 and f14, yet.
Comment 10 Tadej Janež 2011-02-17 05:52:59 EST
(In reply to comment #9)
> (In reply to comment #8)
> 
> > > I'll try to come up with an updated package tomorrow.
> > 
> > I tried again today and it failed. From looking at the spec file, I think you
> > forgot to apply the patch to the sources?
> 
> What are you looking at?

I'm looking at http://pkgs.fedoraproject.org/gitweb/?p=gtkglext.git;a=blob;f=gtkglext.spec;h=8671084101f3ea84c96f8ae2a389df19538937ef;hb=d1a927669ce8d5329739c554595d492fa41d982f
 
> The "supposed to be fix" has been applied to git for rawhide and f15, only.

I know. I tried rebuilding against rawhide and did a double check that the build root had the new package (gtkglext-devel-1.2.0-13.fc16.x86_64).

See my failed build here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2845985
I was rebuilding this SRPM:
http://tadej.fedorapeople.org/techne-0.2.1-1.fc16.src.rpm
Comment 11 Ralf Corsepius 2011-02-17 06:40:56 EST
Ouch - I missed to apply the patch 8(=)

Next attempt: *-14.*
Comment 12 John Ellson 2011-02-17 12:01:29 EST
Thanks Ralf and Tadej,

I've verified that gtkglext*  1.2.0-14  works for me (graphviz upstream build) on fc15 and fc16, i686 and x86_64.

(re: Comment 4.  You need use "./configure --with-smyrna" with graphviz to pull in the GL features that tickle the problem. Its the default in the upstream .spec, but may not be in the version currently in Fedora.  Sorry for making the problem hard to reproduce. )

Note You need to log in before you can comment on or make changes to this bug.