Bug 67753 - ldap is started too late in the boot process. Needs to be sooner than autofs since autofs can load its config based on it.
ldap is started too late in the boot process. Needs to be sooner than autofs ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: openldap (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-01 13:03 EDT by Bill Peck
Modified: 2014-08-31 19:24 EDT (History)
3 users (show)

See Also:
Fixed In Version: openldap-2_2_23-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-11 12:00:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Peck 2002-07-01 13:03:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
I have a server installed with openldap-2.0.23-4 and the startup order is set 
to 39.  This is much too late in the boot sequence since autofs starts at 28. 
This is fine for all the client machines but the server does not load its auto 
mount entries because ldap is not running when autofs starts.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install openldap and autofs
2. configure ldap to serve automount entries for autofs
3. reboot the server machine.  automount will run and complain of no maps.
	

Actual Results:  autofs doesn't load the servers automount maps.

Expected Results:  ldap should be running and autofs should load the automount 
maps

Additional info:

I have manually changed the boot sequence for openldap to be before autofs and 
have not had any ill effects from this change.

Please consider fixing this in a later release.

Thanks!
Comment 1 Stephen Walton 2003-02-14 19:17:45 EST
This bug is still present in RedHat 8.0.
Comment 2 Stephen Walton 2003-02-14 19:24:43 EST
Sorry, one more comment:  In addition to starting ldap before autofs, ldap needs
to be stopped after autofs, otherwise system shutdown fails.  I changed the
chkconfig line in /etc/rc.d/init.d/ldap to '# chkconfig: 345 27 73' so that it
starts right before autofs and stops right after.


Comment 3 Steven Pritchard 2005-05-02 13:02:06 EDT
This bug is also still present in both Fedora Core 2 and 3.
Comment 4 Jay Fenlason 2006-01-11 12:00:59 EST
According to the CVS log, this was fixed in Fedora Core 4. 

Note You need to log in before you can comment on or make changes to this bug.