This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 677549 - rhnpush dependency spacewalk-backend-libs-1.2.13-30 breaks dependency during upgrade from sat5.3 to sat5.4
rhnpush dependency spacewalk-backend-libs-1.2.13-30 breaks dependency during ...
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades (Show other bugs)
540
Unspecified Unspecified
urgent Severity high
: ---
: ---
Assigned To: Miroslav Suchý
Jiri Kastner
:
Depends On: 648403
Blocks: sat54-errata
  Show dependency treegraph
 
Reported: 2011-02-15 03:03 EST by Jiri Kastner
Modified: 2011-03-07 04:23 EST (History)
5 users (show)

See Also:
Fixed In Version: spacewalk-backend-1.2.13-32
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-07 04:23:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jiri Kastner 2011-02-15 03:03:00 EST
Description of problem:
new rhnpush from bug 648403 introduced as dependency spacewalk-backend-libs which are newer then in sat 5.4.0, so upgrade fails

Version-Release number of selected component (if applicable):
spacewalk-backend-libs-1.2.13-30

How reproducible:


Steps to Reproduce:
1. install satellite 5.3.0
2. install rhnpush and spacewalk-backend-libs from 648403
3. try upgrade to sat 5.4.0
4. upgrade fails
  
Actual results:
# tail /var/log/rhn/rhn-installation.log
---> Package spacewalk-backend.noarch 0:1.2.13-11.el5sat set to be updated
--> Processing Dependency: spacewalk-backend-libs = 1.2.13-11.el5sat for
package: spacewalk-backend
--> Finished Dependency Resolution
spacewalk-backend-1.2.13-11.el5sat.noarch from
/spacewalk-backend-1.2.13-11.el5sat.noarch has depsolving problems
  --> Missing Dependency: spacewalk-backend-libs = 1.2.13-11.el5sat is
needed by package spacewalk-backend-1.2.13-11.el5sat.noarch
(/spacewalk-backend-1.2.13-11.el5sat.noarch)
Error: Missing Dependency: spacewalk-backend-libs = 1.2.13-11.el5sat is
needed by package spacewalk-backend-1.2.13-11.el5sat.noarch
(/spacewalk-backend-1.2.13-11.el5sat.noarch)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest


Expected results:
upgrades proceed, maybe some notice in steps in rhn-upgrade package

Additional info:
Comment 2 Clifford Perry 2011-02-15 13:40:47 EST
RHN Tools is not a child channel which *should* be enabled for a Satellite registered to RHN. 

BUT we do not tell folks to specifically exclude them either. As such - I think we need to put the RHN Tools errata on hold to resolve this issue before we allow the Errata to go out. 


http://docs.redhat.com/docs/en-US/Red_Hat_Network_Satellite/5.4/html/Installation_Guide/s1-requirements-additional.html

"Do not subscribe your RHN Satellite to any of the following child channels available on RHN Hosted:
    * Red Hat Developer Suite
    * Red Hat Application Server
    * Red Hat Extras "

Cliff
Comment 3 Clifford Perry 2011-02-15 13:43:05 EST
If upgrades need to rpm -e packages prior to upgrade. OK. but that errata will need to block the other's release. Or we re-look at the other bug's solution to determine if alternative is better. 

Cliff
Comment 4 Miroslav Suchý 2011-02-16 05:11:00 EST
Taking for investigation.
Comment 5 Miroslav Suchý 2011-02-16 10:29:58 EST
Well, this will be long... 

The cause is this line in spacewalk-backend:
Requires: %{name}-libs = %{version}-%{release}
This was added in commit 370ca2d8 and therefore it is present only in RHN Satellite 5.4.

I'm ignoring Spacewalk as there is no split of server and tools so there this problem does not exist.

I fixed this requires in spacewalk.git in commit eb248c97031fa2c08e372fe04984dd4add9c77fc to sane value (based on my investigation of commits in backend/common).
But even if I cherrypick this change to satellite.git this will *not* fix this problem as. Because even if we release new spacewalk-backend as errata, this bug is happenning when you are upgrading from Sat5.3 (not affected) to Sat5.4. And remember - you are upgrading to packages which are on ISO, so errata will not help here.

I see several options here. None is perfect. In fact all are quite ugly.

1. WONTFIX and optionaly document it in rhn-upgrade - something like --nodeps :(

2. Put into current spacewalk-backend-libs (and release it in RHN Tools) additional provides, which will be same as  %{version}-%{release} of spacewalk-backend package which is on ISO. But that means that spacewalk-backend-libs will provide *two* different versions and it may kick us in future when we will want conflict/obsolete/whatever with one of these version.

3. build new spacewalk-backend and respin RHN Satellite 5.4 iso.

4. if we are going to build ISO for RHN Satellite 5.4.1, then postpone it and fix it on 5.4.1 ISO.

Good, worse and ugly. :(
Comment 8 Miroslav Suchý 2011-02-17 11:28:40 EST
Fixed in satellite.git in commits
377f0af9c487b96b425586b37793aed159faca29
1fe68dadb23986ccb44beaca8588958871c49b3c
Comment 9 Jiri Kastner 2011-02-18 03:38:40 EST
[root@hp-sl2x170zg6-01 sat540]# rpm -q --provides spacewalk-backend-libs
spacewalk-backend-libs = 1.2.13-11
spacewalk-backend-libs = 1.2.13-31.el5sat


  --> Missing Dependency: spacewalk-backend-libs = 1.2.13-11.el5sat is needed by package spacewalk-backend-1.2.13-11.el5sat.noarch (/spacewalk-backend-1.2.13-11.el5sat.noarch)
Error: Missing Dependency: spacewalk-backend-libs = 1.2.13-11.el5sat is needed by package spacewalk-backend-1.2.13-11.el5sat.noarch (/spacewalk-backend-1.2.13-11.el5sat.noarch)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
Comment 10 Jiri Kastner 2011-02-25 08:26:33 EST
Updated:
  cobbler.noarch 0:2.0.7-5.el5sat                                      firefox.i386 0:3.6.14-3.el5_6                                      firefox.x86_64 0:3.6.14-3.el5_6                                     
  jabberd.x86_64 0:2.2.8-10.el5sat                                     koan.noarch 0:2.0.7-6.el5sat                                       ksh.x86_64 0:20100202-1.el5_6.3                                     
  openldap.i386 0:2.3.43-12.el5_6.6                                    openldap.x86_64 0:2.3.43-12.el5_6.6                                openldap-devel.i386 0:2.3.43-12.el5_6.6                             
  openldap-devel.x86_64 0:2.3.43-12.el5_6.6                            python-hashlib.x86_64 0:20081119-6.el5                             rhncfg.noarch 0:5.9.27-15.el5                                       
  rhncfg-actions.noarch 0:5.9.27-15.el5                                rhncfg-client.noarch 0:5.9.27-15.el5                               rhncfg-management.noarch 0:5.9.27-15.el5                            
  rhnpush.noarch 0:5.5.4-9.el5sat                                      satellite-schema.noarch 0:5.4.0.9-1.el5sat                         spacewalk-backend.noarch 0:1.2.13-26.2.el5sat                       
  spacewalk-backend-app.noarch 0:1.2.13-26.2.el5sat                    spacewalk-backend-applet.noarch 0:1.2.13-26.2.el5sat               spacewalk-backend-config-files.noarch 0:1.2.13-26.2.el5sat          
  spacewalk-backend-config-files-common.noarch 0:1.2.13-26.2.el5sat    spacewalk-backend-config-files-tool.noarch 0:1.2.13-26.2.el5sat    spacewalk-backend-iss.noarch 0:1.2.13-26.2.el5sat                   
  spacewalk-backend-iss-export.noarch 0:1.2.13-26.2.el5sat             spacewalk-backend-libs.noarch 0:1.2.13-32.el5sat                   spacewalk-backend-package-push-server.noarch 0:1.2.13-26.2.el5sat   
  spacewalk-backend-server.noarch 0:1.2.13-26.2.el5sat                 spacewalk-backend-sql.noarch 0:1.2.13-26.2.el5sat                  spacewalk-backend-sql-oracle.noarch 0:1.2.13-26.2.el5sat            
  spacewalk-backend-tools.noarch 0:1.2.13-26.2.el5sat                  spacewalk-backend-upload-server.noarch 0:1.2.13-26.2.el5sat        spacewalk-backend-xml-export-libs.noarch 0:1.2.13-26.2.el5sat       
  spacewalk-backend-xmlrpc.noarch 0:1.2.13-26.2.el5sat                 spacewalk-backend-xp.noarch 0:1.2.13-26.2.el5sat                   spacewalk-base.noarch 0:1.2.7-14.el5sat                             
  spacewalk-base-minimal.noarch 0:1.2.7-14.el5sat                      spacewalk-dobby.noarch 0:1.2.7-14.el5sat                           spacewalk-grail.noarch 0:1.2.7-14.el5sat                            
  spacewalk-html.noarch 0:1.2.7-14.el5sat                              spacewalk-java.noarch 0:1.2.39-35.1.el5sat                         spacewalk-java-config.noarch 0:1.2.39-35.1.el5sat                   
  spacewalk-java-lib.noarch 0:1.2.39-35.1.el5sat                       spacewalk-java-oracle.noarch 0:1.2.39-35.1.el5sat                  spacewalk-pxt.noarch 0:1.2.7-14.el5sat                              
  spacewalk-sniglets.noarch 0:1.2.7-14.el5sat                          spacewalk-taskomatic.noarch 0:1.2.39-35.1.el5sat                   tomcat5.x86_64 0:5.5.23-0jpp.17.el5_6                               
  tomcat5-common-lib.x86_64 0:5.5.23-0jpp.17.el5_6                     tomcat5-jasper.x86_64 0:5.5.23-0jpp.17.el5_6                       tomcat5-jsp-2.0-api.x86_64 0:5.5.23-0jpp.17.el5_6                   
  tomcat5-server-lib.x86_64 0:5.5.23-0jpp.17.el5_6                     tomcat5-servlet-2.4-api.x86_64 0:5.5.23-0jpp.17.el5_6              xulrunner.i386 0:1.9.2.14-3.el5_6                                   
  xulrunner.x86_64 0:1.9.2.14-3.el5_6                                  xulrunner-devel.i386 0:1.9.2.14-3.el5_6                            xulrunner-devel.x86_64 0:1.9.2.14-3.el5_6                           

Complete!
Comment 11 Jiri Kastner 2011-02-25 08:28:11 EST
detail:
....
spacewalk-backend-iss-export.noarch 0:1.2.13-26.2.el5sat
spacewalk-backend-libs.noarch 0:1.2.13-32.el5sat
spacewalk-backend-package-push-server.noarch 0:1.2.13-26.2.el5sat
...
Comment 13 errata-xmlrpc 2011-03-07 04:23:22 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0323.html

Note You need to log in before you can comment on or make changes to this bug.