Bug 677654 - [abrt] SIGABRT: attach_thread
Summary: [abrt] SIGABRT: attach_thread
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gdb
Version: 14
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Kratochvil
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:9ff84c8d5463bc4ce9fa2573fc3...
: 674120 679268 680307 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-15 14:00 UTC by François petrisot
Modified: 2011-03-05 02:35 UTC (History)
14 users (show)

Fixed In Version: gdb-7.2-45.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-05 02:35:29 UTC


Attachments (Terms of Use)
File: backtrace (17.61 KB, text/plain)
2011-02-15 14:00 UTC, François petrisot
no flags Details

Description François petrisot 2011-02-15 14:00:00 UTC
abrt version: 1.1.14
architecture: x86_64
Attached file: backtrace
cmdline: gdb -batch -ex 'set debug-file-directory /usr/lib/debug:/var/cache/abrt-di/usr/lib/debug' -ex 'file /usr/bin/evolution' -ex 'core-file /var/spool/abrt/ccpp-1293092226-3787/coredump' -ex 'thread apply all backtrace 2048 full' -ex 'info sharedlib' -ex 'print (char*)__abort_msg' -ex 'print (char*)__glib_assert_msg' -ex 'info registers' -ex disassemble
component: gdb
executable: /usr/bin/gdb
kernel: 2.6.35.11-83.fc14.x86_64
package: gdb-7.2-41.fc14
reason: Process /usr/bin/gdb was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1297778100
uid: 1424

How to reproduce
-----
1.generate automatic bug reporting bug
2.
3.

Comment 1 François petrisot 2011-02-15 14:00:03 UTC
Created attachment 478879 [details]
File: backtrace

Comment 2 Theophanis Kontogiannis 2011-02-15 18:57:05 UTC
Package: gdb-7.2-41.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. reporting bug ID677759
2.
3.

Comment 3 Theophanis Kontogiannis 2011-02-15 19:26:14 UTC
Package: gdb-7.2-41.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. reporting bug id=677767
2.
3.

Comment 4 Javier Jardón 2011-02-16 14:35:49 UTC
Package: gdb-7.2-41.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. I try to put a breakpoint wharn debugging a program

Maybe selinux related?

Comment 5 Jan Kratochvil 2011-02-16 15:32:31 UTC
I do not think it is SELinux related.

Do you have it reproducible?

It should get fixed by changing the iterator from libthread_db to /proc/PID/task/ readdir, which is planned for some years.

Comment 6 Javier Jardón 2011-02-16 15:44:11 UTC
Sorry, I can't reproduce it.

But I have another strange behaviour maybe related: I can't set breakpoints, this is the error:

"Cannot insert breakpoint 1.
 Error accessing memory address 0x3b24481778: Input/output error."

Comment 7 Jan Kratochvil 2011-02-16 15:55:22 UTC
(In reply to comment #6)
> "Cannot insert breakpoint 1.
>  Error accessing memory address 0x3b24481778: Input/output error."

This error is known but one needs a reproducer.  For example GDB may erroneously compute invalid address of a breakpoint where is no memory mapped.

This one can be due to SELinux I think, you should check your /var/log/* (/var/log/messages probably).

Comment 8 Javier Jardón 2011-02-16 16:09:16 UTC
I disabled selinux (SELINUX=permissive in /etc/selinux/config) and the problem persist, should I fill a different bug?

Comment 9 Jan Kratochvil 2011-02-16 16:15:41 UTC
It is enough + easier to just run `setenforce 0' for such test.
Yes, the `Error accessing memory address' is unrelated to this Bug.
We need a reproducer of that error message to be able to do anything with it.

Comment 10 Javier Jardón 2011-02-16 17:32:51 UTC
ok, submitted a different bug about this issue in bug #678098

Comment 11 Robert V. Miciovici 2011-02-17 17:14:10 UTC
Package: gdb-7.2-41.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.
2.
3.
while reporting a bug it just crashed

Comment 12 Jan Kratochvil 2011-02-17 17:30:18 UTC
Could you send the core file GDB was trying to backtrace/report?

Comment 13 eatmeatagain 2011-02-19 08:39:28 UTC
Package: gdb-7.2-41.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. start sending automatic bug report for pulseaudio
2.
3.


Comment
-----
this crash occurred while the automatic bug reporting tool was gathering debug stuff for a pulseaudio crash

Comment 14 Clément DAVID 2011-02-21 16:49:01 UTC
Package: gdb-7.2-41.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. while debugging fortran code from scilab (www.scilab.org)
2. put a break on fortran code
3. on break gdb crash.

Comment 15 Clément DAVID 2011-02-21 16:51:35 UTC
should be related to bug 654331

Comment 16 Jan Kratochvil 2011-02-24 02:00:44 UTC
*** Bug 679268 has been marked as a duplicate of this bug. ***

Comment 17 Jan Kratochvil 2011-02-24 02:02:03 UTC
*** Bug 674120 has been marked as a duplicate of this bug. ***

Comment 18 Jan Kratochvil 2011-02-24 05:16:15 UTC
[patch 2/3] Fix threading internal error on corrupted memory
http://sourceware.org/ml/gdb-patches/2011-02/msg00674.html

Comment 19 Fedora Update System 2011-02-24 09:28:46 UTC
gdb-7.2-45.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/gdb-7.2-45.fc14

Comment 20 Fedora Update System 2011-02-24 20:57:58 UTC
gdb-7.2-45.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gdb'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/gdb-7.2-45.fc14

Comment 21 Jan Kratochvil 2011-02-25 05:56:16 UTC
*** Bug 680307 has been marked as a duplicate of this bug. ***

Comment 22 meowcatscatsmeow 2011-02-26 12:22:07 UTC
Package: gdb-7.2-41.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.ran chkrootkit
2. crashed
3. no profit :(


Comment
-----
tried to run chkrootkit under system tools... failed!

Comment 23 Dilipa Rout 2011-03-03 06:39:10 UTC
Package: gdb-7.2-41.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. No idea how gdb crashed
2.
3.

Comment 24 Dilipa Rout 2011-03-03 07:18:06 UTC
Package: gdb-7.2-41.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.after installation gdb crashed
2.
3.

Comment 25 Serg Merkelov 2011-03-03 21:23:48 UTC
Package: gdb-7.2-41.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. try to send another bug report via abrt :)
2.
3.

Comment 26 Fedora Update System 2011-03-05 02:35:13 UTC
gdb-7.2-45.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.