Bug 67766 - Rawhide's qt-3.04-5 and 6 break KDE (konsole and quicklauncher, and probably others too)
Rawhide's qt-3.04-5 and 6 break KDE (konsole and quicklauncher, and probably ...
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: qt3 (Show other bugs)
1.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: wdovlrrw
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-01 16:44 EDT by Alain Knaff
Modified: 2008-05-01 11:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-02 04:41:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alain Knaff 2002-07-01 16:44:26 EDT
Description of Problem:  
  
qt-3.0.4-6 and qt-3.0.4-7 as shipped with rawhide break KDE. 
This can be seen by two symptoms: 
- konsole has a "funny" font (extra wide, doublespaced) 
- Passing the mouse cursor over the small icons in the 
quicklauncher panel applet "wipes out" those icons, 
especially those in the bottom row. 
qt-3.0.4-5 (which I fortunately kept around) works ok. 
 
Version-Release number of selected component (if applicable):  
  
qt-3.0.4-6 or qt-3.0.4-7 
 
How Reproducible:  
 
Always. 
  
Steps to Reproduce:  
A: 
1. Start konsole, and admire that strange font! 
 
B: 
1. Pass mouse cursor over quicklauncher panel applet 
2. Click on panel icons 
3. Wait a while 
4. You'll notice that a couple of icons in the lower row of 
the quicklauncher just disappear! 
 
Actual Results:  
 
Strange font in konsole (doublespaced: between each 
character, there seems to be an extra space character) 
Icons in quicklauncher disappear 
 
Expected Results:  
  
Normal font in konsole (as it was until 3.0.4-5) 
Quicklauncher icons should stay put. 
 
Additional Information:  
 
This problem has now been existing for over a week, 
(qt-3.0.4-6, the first to break this stuff is dated June 
21st), with no sign of progress (qt-3.0.4-7 has been released 
with the same bug...)
Comment 1 Bernhard Rosenkraenzer 2002-07-02 04:41:42 EDT
The font problem is caused by fontconfig (new X font management system) trying  
to merge all possible charsets into one font, so konsole sees the width of  
Chinese/Japanese characters when determining the right spacing.  
 
The (not 100% reproducable) icon problem is also caused by the switch to Xft2, 
though I haven't debugged it enough to see whether it's a problem with Xft2 
itself or with the way Qt uses it (the only change between 3.0.4-5 and 3.0.4-6 
was adding support for Xft2).

Note You need to log in before you can comment on or make changes to this bug.