Bug 677725 - port allocation/deallocation is wrong [in libnl-1.1-12]
Summary: port allocation/deallocation is wrong [in libnl-1.1-12]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libnl
Version: 6.1
Hardware: Unspecified
OS: Linux
high
urgent
Target Milestone: rc
: ---
Assignee: Laine Stump
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 677729
TreeView+ depends on / blocked
 
Reported: 2011-02-15 17:02 UTC by Daniel Berrangé
Modified: 2017-02-06 14:36 UTC (History)
13 users (show)

Fixed In Version: libnl-1.1-14.el6
Doc Type: Bug Fix
Doc Text:
The port allocation/de-allocation was not safe in multi-threaded applications and the logic was incorrect, which resulted in some applications and other libraries being unable to initialize libnl. Port allocation/de-allocation and logic is now fixed, and libnl can now be initialized.
Clone Of: 677526
Environment:
Last Closed: 2011-05-19 14:29:53 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0795 normal SHIPPED_LIVE libnl bug fix update 2011-05-18 18:08:09 UTC

Description Daniel Berrangé 2011-02-15 17:02:26 UTC
+++ This bug was initially created as a clone of Bug #677526 +++

Description of problem:

port allocation (socket.c ; line 134):
used_ports_map[i] |= (1UL << n);

- that's going to set a bit

port deallocation (socket.c; line 156) :
used_ports_map[nr / 32] &= ~((nr % 32) + 1);


- that's going to produce garbage [no wonder things don't work]


used_ports_map[nr / 32] &= ~(1 << (nr % 32));

or

used_ports_map[nr / 32] &= ~(1 << (nr & 0x1f));

- would probably be much better 




Version-Release number of selected component (if applicable):

libnl-1.1-12.fc14.x86_64
libnl-debuginfo-1.1-12.fc14.x86_64
libnl-devel-1.1-12.fc14.x86_64

Comment 2 Daniel Berrangé 2011-02-15 17:05:03 UTC
This bug is causing failures in libvirt's VEPA support in some scenarios (see upstream thread http://www.redhat.com/archives/libvir-list/2011-February/msg00466.html)

Comment 3 RHEL Product and Program Management 2011-02-15 17:17:53 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 5 Stefan Berger 2011-02-25 00:43:43 UTC
Dear 'Red Hat Product Management', the correct functioning of other components, i.e., those in libvirt, depend on the correct functioning of libnl. So, we would like to propose this request for RHEL 6.1.

Comment 14 Laine Stump 2011-03-28 06:50:51 UTC
A fix for this bug has been applied and is included in libnl-1.1-14.el6:

   https://brewweb.devel.redhat.com/buildinfo?buildID=160656

Comment 17 Laine Stump 2011-04-06 14:50:20 UTC
This error:

  error: internal error failed to get number of interfaces on host (netcf:
  unspecified error - errors in loading some config files)
  error:Failed to list active interfaces

is unrelated to the libnl problems. It is caused by Bug 690286. You will need to install augeas-0.7.2-6.el6 to eliminate that problem.

Comment 19 Misha H. Ali 2011-05-03 01:30:11 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The port allocation/de-allocation was not safe in multi-threaded applications and the logic was incorrect, which resulted in some applications and other libraries being unable to initialize libnl. Port allocation/de-allocation and logic is now fixed, and libnl can now be initialized.

Comment 20 errata-xmlrpc 2011-05-19 14:29:53 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0795.html


Note You need to log in before you can comment on or make changes to this bug.