Bug 67776 - With cluster turned off, cluadmin 'cluster status' gets error "cluGetDiskNodesStates failed"
With cluster turned off, cluadmin 'cluster status' gets error "cluGetDiskNode...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: clumanager (Show other bugs)
2.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Lon Hohberger
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-01 17:50 EDT by Hardy Merrill
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-11 10:28:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hardy Merrill 2002-07-01 17:50:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
While testing the fix to bugzilla bug 63176, I found this - after turning the
cluster off with 'service cluster stop', when you get into cluadmin and do
'cluster status', it lists the status of the cluster, but at the bottom is the
message:

  cluGetDiskNodeStates failed.

I'm not sure if this is a bug, but I decided to enter it and let the developer
decide.  This seems like a problem to me.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Stop the cluster software with 'service cluster stop'.
2.Enter 'cluadmin'.
3.At the cluadmin prompt "cluadmin>", enter 'cluster status'
  and press ENTER.

  You will get a listing of the cluster status, but the last line
  will be

    cluGetDiskNodeStates failed.
	

Additional info:
Comment 1 Lon Hohberger 2002-07-09 13:51:33 EDT
This is because cluadmin merely calls "clustat -v -i0" when an administrator
types "cluster status" at the cluadmin> prompt.  "clustat -v" turns on the
verbose flag, which displays this message.
Comment 2 Lon Hohberger 2002-07-17 18:04:22 EDT
Fix in pool.

Note You need to log in before you can comment on or make changes to this bug.