Bug 677797 - Broken dependency: hugin-base-2010.4.0-4.fc15.x86_64 requires libpano13.so.2()(64bit)
Broken dependency: hugin-base-2010.4.0-4.fc15.x86_64 requires libpano13.so.2(...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hugin (Show other bugs)
15
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bruno Postle
Fedora Extras Quality Assurance
repoclosure_hash:722c96a041c58a270119...
:
Depends On:
Blocks: F15Alpha/F15AlphaBlocker
  Show dependency treegraph
 
Reported: 2011-02-15 16:22 EST by James Laska
Modified: 2013-09-02 02:53 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-18 12:42:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Laska 2011-02-15 16:22:40 EST
Added repo-1 repo from /media
Reading in repository metadata - please wait....
Checking Dependencies
Repos looked at: 1
   repo-1
Num Packages in Repos: 2922
package: hugin-base-2010.4.0-4.fc15.x86_64 from repo-1
  unresolved deps: 
     libpano13.so.2()(64bit)
Comment 1 James Laska 2011-02-15 16:27:04 EST
This issue is proposed as a Fedora 15 Alpha release blocker due to the following Alpha release criteria [1]

   There must be no file conflicts (cases where the files in some 
   packages conflict but the packages have explicit Conflicts: 
   tags are acceptable) or unresolved package dependencies during
   a media-based (CD/DVD) install 

https://fedoraproject.org/wiki/Fedora_15_Alpha_Release_Criteria
Comment 2 Bruno Postle 2011-02-15 16:44:36 EST
I didn't break it.  f15 had libpano13-2.9.17 when I built the hugin-2010.4.0 package that is currently in f15 on Jan 12th and Feb 4th.

Somebody built and pushed the old libpano13-2.9.14 into f15 on Feb 8th, I don't know why - even f14 has libpano13-2.9.17.

I guess it is up to me to fix it...
Comment 3 James Laska 2011-02-15 16:50:32 EST
(In reply to comment #2)
> I didn't break it.

Sorry, we don't yet have a mechanism to block updates that introduce dependency problems.  It's entirely possible that other packages can introduce dependency problems with packages you maintain.

> I guess it is up to me to fix it...

I'm filing this bug to start the discussion.  I figure you are likely in a better position to best determine what needs to change in order to resolve this dependency conflict.  We can certainly adjust the component and ownership based on your recommendation.
Comment 4 Bruno Postle 2011-02-15 17:11:24 EST
I'm the maintainer of both libpano13 and hugin.  I don't know why somebody removed the libpano13-2.9.17 package and replaced it with libpano13-2.9.14.

Looking at git the f15 spec file is for 2.9.17, I guess I'll just try building again and see if that fixes it.
Comment 5 Bruno Postle 2011-02-15 18:28:11 EST
It looks like 2.9.17 was already built for f15 yesterday: http://koji.fedoraproject.org/koji/buildinfo?buildID=228678

What a waste of an evening, I have better things to do.
Comment 6 James Laska 2011-02-16 09:27:03 EST
(In reply to comment #5)
> It looks like 2.9.17 was already built for f15 yesterday:
> http://koji.fedoraproject.org/koji/buildinfo?buildID=228678

That link shows the last build was in September, 2010.

* Sat Sep 11 2010 Terry Duell 2.9.17-1 - New upstream release with soname increment

Unless I'm misunderstanding, I believe the problem remains.

> What a waste of an evening, I have better things to do.

I'm sorry about you're evening.  If the responsibilities of package ownership are difficult to sustain, you may wish to solicit a co-maintainer or seek a new maintainer.

https://fedoraproject.org/wiki/Package_maintainer_policy#Co-Maintainership
Comment 7 James Laska 2011-02-16 09:30:11 EST
(In reply to comment #6)
> (In reply to comment #5)
> > It looks like 2.9.17 was already built for f15 yesterday:
> > http://koji.fedoraproject.org/koji/buildinfo?buildID=228678
> 
> That link shows the last build was in September, 2010.
> 
> * Sat Sep 11 2010 Terry Duell 2.9.17-1 - New upstream release with soname
> increment
> 
> Unless I'm misunderstanding, I believe the problem remains.

Ah, interesting ... no one updated the %changelog of that rebuilt package.  Bad :)

But the newer libpano13 was indeed built recently (Mon, 14 Feb 2011 16:30:51 UTC).  I'm moving this to MODIFIED.  We can move to ON_QA once a bodhi update for libpano13-2.9.17-1.fc15 is available for testers.

Thanks!
Comment 8 Rex Dieter 2011-02-16 10:14:16 EST
I took care of this Monday (2-14), I assumed you'd get CC'd the commits and koji notifications.  

In short, a f14 update had been done (abi break), but master/ branch wasn't updated, so when the mass rebuild was done (using master/), libpano13 was essentially downgraded and resulted in broken deps.  What I did on Monday was to sync master/ and f15/ with f14/ and issued a newer f15 build, then we (with my rel-eng hat on), manually tagged this into dist-f15 so the kde spin could get composed properly for f15alpha.
Comment 9 Bruno Postle 2011-02-16 18:35:07 EST
(In reply to comment #8)
> I took care of this Monday (2-14), I assumed you'd get CC'd the commits and
> koji notifications.  

Thanks for the explanation. The scm-commits emails don't contain any info when 'commit already existed in another branch', so I only saw the commits with changes related to the old libpano13-2.9.14 in f15. 

I haven't had a Koji email since July 2009, I assumed they had been discontinued.
Comment 10 Adam Williamson 2011-02-18 12:42:22 EST
[root@adam Fedora]# yum install hugin
...
===============================================================================
 Package           Arch          Version                   Repository     Size
===============================================================================
Installing:
 hugin             x86_64        2010.4.0-4.fc15           fedora        5.5 M
Installing for dependencies:
 hugin-base        x86_64        2010.4.0-4.fc15           fedora        5.8 M
 libpano13         x86_64        2.9.17-1.fc15             fedora        229 k

Transaction Summary
===============================================================================
Install       3 Package(s)

Total download size: 11 M
Installed size: 35 M
Is this ok [y/N]: y
Downloading Packages:
Setting up and reading Presto delta metadata
fedora/prestodelta                                      | 2.4 MB     00:01     
Processing delta metadata
Package(s) data still to download: 11 M
(1/3): hugin-2010.4.0-4.fc15.x86_64.rpm                 | 5.5 MB     00:03     
(2/3): hugin-base-2010.4.0-4.fc15.x86_64.rpm            | 5.8 MB     00:03     
(3/3): libpano13-2.9.17-1.fc15.x86_64.rpm               | 229 kB     00:00     
-------------------------------------------------------------------------------
Total                                          1.4 MB/s |  11 MB     00:08     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : libpano13-2.9.17-1.fc15.x86_64                              1/3 
  Installing : hugin-base-2010.4.0-4.fc15.x86_64                           2/3 
  Installing : hugin-2010.4.0-4.fc15.x86_64                                3/3 

Installed:
  hugin.x86_64 0:2010.4.0-4.fc15                                               

Dependency Installed:
  hugin-base.x86_64 0:2010.4.0-4.fc15     libpano13.x86_64 0:2.9.17-1.fc15    

Complete!

Note You need to log in before you can comment on or make changes to this bug.