Bug 67780 - Installer hangs when loading aic7xxx module with AMD760MPX chipset (onbord AIC on the new Tyan Thunder K7X)
Installer hangs when loading aic7xxx module with AMD760MPX chipset (onbord AI...
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i686 Linux
high Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-01 19:00 EDT by Marco Balle
Modified: 2007-03-26 23:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-03 15:13:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marco Balle 2002-07-01 19:00:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
If i try to boot RedHat 7.2 Installation CD (linux noprobe), it hangs after i 
try to load the aic7xxx driver (the old and the new).


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
*you must have the Tyan Thunder K7X Mainboard
1. boot with the noprobe option
2. load the aic7xxx
3. switch console (alt+F4)
	

Actual Results:  Here is the Error:

* going to insmod aic7xxx.o (path is NULL)
Oops: 0000
CPU: 0
EIP: 0010:[<f8826491>]
EFLAGS: 00010246
eax: ffffffff    ebx: 03000000    ecx: f7634000    edx: f7634000
esi: c216b4e0    edi: 00000000    ebp: 00000000    esp: c022ff20
Process swapper (pid: 0, stackpage=c022f000
Stack: f7642000 f7634040 c2158000 04000001 f8829000 00000006 f8827085 f2158000
       f7634000 c21e5e00 04000001 0000000a c022ff98 c0107fed 0000000a c2158000
       c022ff98 c022ff98 0000000a c024aa40 c21e5e00 c010813c 0000000a c022ff98 
Call Trace: [<f8829000>] [<f8827085>] [<c0107fed>] [<c010813c>] [<c0105344>]
    [<c010a1e8>] [<c0105344>] [<c0105367>] [<c01053ce>] [<c01f2500>]


Code: 66 8b 45 06 40 66 3b 45 04 66 89 45 06 75 34 8b 0c 24 f6 41 <0>
Kernel Panic: Aiee, killing interrupt handler! In interrupt handler - not 
syncing



Expected Results:  load the driver and detect the IBM SCSI disks

Additional info:

I tried also the solution with the 440gx chipset (linux apic), but it does not 
work.
I can not install any RedHat version (tried 7.2 and 7.3) on the new Tyan 
Thunder K7X Mainboards.
I am not sure if the fault comes from the aic7xxx driver, but even if i load 
it, the oops is there.
All other distributions (i tried Debinand SuSE) do not have any problems 
during the installation process.
Comment 1 Marco Balle 2002-07-03 15:13:04 EDT
I found a solution! Use a PS/2 or NO mouse!
The problem is not the aic7xxx, it is the USB!!

I disconnected my USB mouse and everything works.
I can also load the aic7xxx without any problems, if the USB mouse is 
disconnected!

There were some USB errors (timeouts) during the boot process.

Note You need to log in before you can comment on or make changes to this bug.