Bug 677809 - need a way to build NSS without running the test-suite
Summary: need a way to build NSS without running the test-suite
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nss
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Elio Maldonado Batiz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-15 21:47 UTC by Kamil Dudka
Modified: 2011-03-07 20:56 UTC (History)
3 users (show)

Fixed In Version: nss-3.12.9-8.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-02-16 11:50:48 UTC


Attachments (Terms of Use)
changes to run the tests on the check section (1.69 KB, patch)
2011-02-16 04:40 UTC, Elio Maldonado Batiz
no flags Details | Diff

Description Kamil Dudka 2011-02-15 21:47:39 UTC
Description of problem:
the test-suite runs in %build instead of %check


Version-Release number of selected component (if applicable):
all supported version of Fedora and Enterprise Linux are affected


How reproducible:
100%


Steps to Reproduce:
1. rpmbuild --rebuild nss-3.12.9-4.fc15.src.rpm

  
Actual results:
no way to build the package without running the test-suite


Additional info:
If the bug is intentional, both of the following steps should be done:

1) add a huge comment explaining why the deviance is necessary

2) introduce another way to build the package without running the test-suite
   (something as easy as binutils uses)

Comment 1 Elio Maldonado Batiz 2011-02-16 04:40:02 UTC
Created attachment 479015 [details]
changes to run the tests on the check section

Comment 2 Elio Maldonado Batiz 2011-02-16 06:13:18 UTC
Moving the tests on the check section didn't help, rpmbuild --rebuild nss-3.12.9-11.fc16.src.rpm still runs the tests. Not sure about binutils' way of doing things. I may need some help here. Kai, do you have any suggestions?

Comment 3 Kamil Dudka 2011-02-16 10:45:39 UTC
My mistake, 'rpmbuild --rebuild' is actually a wrong reproducer.  'rpmbuild -bc nss.spec' should work fine with this change.  I'll give it a try later today.

Comment 4 Kamil Dudka 2011-02-16 11:50:48 UTC
Works for me.  Closing RAWHIDE.  Thanks for the fix.

Comment 5 Fedora Update System 2011-02-25 00:23:44 UTC
nss-softokn-3.12.9-6.fc15,nss-3.12.9-13.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/nss-softokn-3.12.9-6.fc15,nss-3.12.9-13.fc15

Comment 6 Fedora Update System 2011-02-25 16:13:26 UTC
nss-softokn-3.12.9-4.fc14,nss-3.12.9-8.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/nss-softokn-3.12.9-4.fc14,nss-3.12.9-8.fc14

Comment 7 Fedora Update System 2011-02-27 21:34:42 UTC
Package nss-3.12.9-8.fc13,nss-softokn-3.12.9-5.fc13,nss-util-3.12.9-1.fc13,nspr-4.8.7-1.fc13:
* should fix your issue,
* was pushed to the Fedora 13 updates-testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing nss-3.12.9-8.fc13,nss-softokn-3.12.9-5.fc13,nss-util-3.12.9-1.fc13,nspr-4.8.7-1.fc13'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/nss-3.12.9-8.fc13,nss-softokn-3.12.9-5.fc13,nss-util-3.12.9-1.fc13,nspr-4.8.7-1.fc13
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2011-03-01 04:22:53 UTC
nss-softokn-3.12.9-5.fc14, nss-3.12.9-8.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2011-03-03 03:22:41 UTC
nss-softokn-3.12.9-7.fc15, nss-3.12.9-13.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2011-03-07 20:55:46 UTC
nss-3.12.9-8.fc13, nss-softokn-3.12.9-5.fc13, nss-util-3.12.9-1.fc13, nspr-4.8.7-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.