Bug 67785 - OS hang on DPMS Standby
OS hang on DPMS Standby
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-01 20:21 EDT by Craig Lawson
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-17 21:51:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Craig Lawson 2002-07-01 20:21:48 EDT
Description of Problem:
  When XFree has decides that it is time to transition from xscreensaver to DPMS
standby mode, the OS system can hang if the mouse is moved during the transition.

Version-Release number of selected component (if applicable):
  Red Hat 7.2
  Kernel 2.4.9-31
  XFree86-4.1.0-15
  xscreensaver-3.33-4

How Reproducible:
  Tricky. It's happened to me twice of the last 3 or 4 months, although I
haven't tried too hard to reproduce it.

Steps to Reproduce:
1. xscreensaver options:
     Blanking & Locking:
       Blank After = 10:00, Cycle After = 3:00
     Display Power Management:
       Enabled
       Standby After = 20:00
       Suspend After = 25:00
       Off After     = 30:00
2. Wait for DPMS to enter standby mode. Sometimes the monitor will display an
"entering standby mode" message.
3. As this happens, move the mouse as though to wake up the system and leave the
screen saver.

Actual Results:
Screen enters standby mode. Stays that way. Disk activity light stays off.
Pressing Num Lock or Caps Lock results in no change in the keyboard status
lights. System seems hung. Unfortunately, I do not have another system available
with which to attempt network access. But it sure seems dead to me.

Expected Results:
I expected my Gnome desktop to be redisplayed, as it typically does when the
screen saver is running, or the monitor is in power saving mode, and I move the
mouse.

Additional Information:
  Whatever is happening when the system hangs, it seems to make the CPU very
busy. I have lm_sensors running to monitor my system temperature, and after
letting the system sit in its hung state for 20 minutes and then restarting, the
CPU temp was significantly higher than before the hang. Once rebooted, the
temperature stabilized at the original temperature as expected.

  Nothing special in the system log at the time of failure. There are a bunch of
these suspicious messages, however:
  kernel: [drm:radeon_freelist_get] *ERROR* returning NULL!
(sometimes repeated hundreds of times!)
  In XF86Config-4, I have:
    Section "Device"
        Identifier "Radeon"
        VendorName "ATI"
        Driver     "ati"
        Option     "AGPMode" "2"
    EndSection

  My video card: ATI Radeon 7000 (PCI).
Comment 1 Mike A. Harris 2002-07-10 01:11:11 EDT
The problem you're describing sounds like it would be incredibly difficult
to try and reproduce in order to gather enough data to take a stab at
isolating the problem.  In order to look into this, I will need you to
supply detailed steps to be able to reproduce it easily with a high chance
of reproduceability.  Once every 2 months is something impossible to debug.

If you can start up X, and do a series of individual steps that cause the
problem to occur 100% of the time, or even 80-90% of the time, in short
order, then it would be much more debuggable.  Please try to do this and
provided the detailed steps you've used to reproduce.

Also, once you've been able to reproduce it, can you disable DRI, and
try to reproduce it again many times to see if disabling DRI makes the
problem go away?
Comment 2 Mike A. Harris 2002-07-26 08:20:57 EDT
Hello?
Comment 3 Craig Lawson 2002-07-27 13:07:28 EDT
I'm still here. Sorry, I have not yet had the time to investigate this further.
Similar, though not identical, weirdness has me thinking that I may be on the
wrong track (example: OS hang while screen saver is running, well before DPMS
transition). Also, it could be that my XFree device configuration is incomplete.

Anyway, I apologize for the delay.
Comment 4 Craig Lawson 2002-08-17 21:51:55 EDT
I spent some time trying to reproduce this bug. Couldn't do it, not even once.

I changed my screen saver start and DPMS standby times to 1 and 2 minutes
respectively to expedite the testing.

Turns out my XFree configuration was OK. All of this is with DRI enabled.
Comment 5 Mike A. Harris 2002-09-05 15:57:20 EDT
Sounds like a random weirdness that disappeared.  I'm unable to reproduce,
and you appear to be unable to reproduce now also, so I'm closing the
bug as WORKSFORME (WORKSFORUS).

Note You need to log in before you can comment on or make changes to this bug.