Bug 67789 - demand dial ppp hangs if set to autoboot
Summary: demand dial ppp hangs if set to autoboot
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-02 01:50 UTC by Need Real Name
Modified: 2014-11-25 15:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-16 16:07:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-07-02 01:50:56 UTC
Description of Problem:
If you configure a ppp interface to auto dial mode(for demand dial), and set 
it to start automatically on bootup, it will hang on starting ppp0 until 
network activity trigger the dial for the first time. This unfortunately will 
not happen in the bootup scripts since they wait for ppp0 to come up before 
proceeding to anything else.

How Reproducible:
Very Repeatable

Steps to Reproduce:
1. Create a dialup connection with auto dialing(instead of manual), and setup 
to start on bootup. Leave rest of options default
2. reboot(or run /etc/init.d/network start). It will sit on starting ppp0 
until network activity triggers the first dial
3. 

Actual Results:
Hangs on starting ppp0

Expected Results:
For a demand dial configuration, it should continue past the ppp0 w/out 
waiting for the modem to dial

Additional Information:
We solved this temporarily by changing the ONBOOT='yes' to no, and putting 
an "ifup ppp0 &" in the rc.local.

I remember seeing a setting to avoid this, but I cannot find this anymore.

Comment 1 Marcelo Roccasalva 2002-08-14 12:32:27 UTC
ppp-watch is supposed to continue if given a third parameter "boot" as the
(buggy) man pages states. It is NOT honoured.

Comment 2 Thomas Woerner 2004-08-16 16:07:35 UTC
Please verify this with a newer version of Red Hat Enterprise Linux or
Fedora Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.


Note You need to log in before you can comment on or make changes to this bug.