Bug 6779 - ref-guide errata regarding rescue mode is incorrect
ref-guide errata regarding rescue mode is incorrect
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: rhl-ig-x86 (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Sandra Moore
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-06 12:39 EST by kevinmills
Modified: 2014-08-04 18:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-15 11:59:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kevinmills 1999-11-06 12:39:50 EST
(there wasn't a ref-guide component in Bugzilla - sorry)

The Reference Guide errata explains the new rescue
procedure, but shows the incorrect command to mount your
root filesystem:

mount -t ext2 /dev/hda5 /mnt

This is incorrect.  The root filesystem should be mounted
on /mnt/sysimage since the rescue mode sets paths
using /mnt/sysimage.  Mounting on /mnt renders the rescue
mode unusable since there are directories under /mnt that
are needed.  The /mnt/sysimage directory does *not* exist
either; it must be created by the user.
Comment 1 Brock Organ 2000-06-15 11:58:36 EDT
on the online 6.2 GSG manual, this mount command example is changed:

"However, if your root filesystem is undamaged, you can mount it and then run
any standard Linux utility. For example, suppose your root filesystem is in
/dev/hda5. Here's how to mount this partition:

mount -t ext2 /dev/hda5 /foo

Where /foo is a directory that you have created.
   
Now you can run chroot, fsck, man, and other utilities. At this point, you are
running Linux in single-user mode."
Comment 2 Brock Organ 2000-06-15 11:59:07 EDT
thanks for your report!

Note You need to log in before you can comment on or make changes to this bug.