Bug 677910 - git completion doesn't suggest branch names any more
Summary: git completion doesn't suggest branch names any more
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: bash
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Roman Rakus
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-16 09:17 UTC by Paul Bolle
Modified: 2014-01-13 00:13 UTC (History)
8 users (show)

Fixed In Version: bash-4.2.0-2.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-03 03:31:05 UTC
Type: ---


Attachments (Terms of Use)

Description Paul Bolle 2011-02-16 09:17:20 UTC
Description of problem:
git completion doesn't suggest branch names any more

Version-Release number of selected component (if applicable):
1.7.4-2, perhaps 1.7.4-1

How reproducible:
Always

Steps to Reproduce:
1. Try completion on a git (sub) command where branch names make sense
2.
3.
  
Actual results:
No branch names are suggested for completion

Expected results:
Branch names should be suggested too

Additional info:
I haven't looked at this yet. It could simply be that some default changed without me noticing (or whatever).

Comment 1 Todd Zullinger 2011-02-16 15:01:12 UTC
Is this only on rawhide or is Fedora 14 affected as well?  In rawhide bash 4.2rc2 was recently built and could be the cause.  Bash-4.2 final was released upstream just a day or so ago.  If the problem is related to the new bash, testing with the final release when it lands in rawhide might be worthwhile.

Comment 2 Adam Tkac 2011-02-16 15:38:19 UTC
After inspection this is bash issue. Note the latest bash-4.2.0-2.fc16 works fine.

Comment 3 Adam Tkac 2011-02-16 15:39:11 UTC
(In reply to comment #2)
> After inspection this is bash issue. Note the latest bash-4.2.0-2.fc16 works
> fine.

Would it be possible to include the fix also in F15, please?

Comment 4 Roman Rakus 2011-02-16 15:49:15 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > After inspection this is bash issue. Note the latest bash-4.2.0-2.fc16 works
> > fine.
> 
> Would it be possible to include the fix also in F15, please?

Sure thing.

Comment 5 Fedora Update System 2011-02-16 16:02:26 UTC
bash-4.2.0-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/bash-4.2.0-2.fc15

Comment 6 Fedora Update System 2011-02-16 21:29:29 UTC
bash-4.2.0-2.fc15 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bash'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/bash-4.2.0-2.fc15

Comment 7 Fedora Update System 2011-03-03 03:30:58 UTC
bash-4.2.0-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.