This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 677917 - fontforge-20100501-python27.patch breaks python module
fontforge-20100501-python27.patch breaks python module
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fontforge (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks: F15Blocker/F15FinalBlocker 631402 631412
  Show dependency treegraph
 
Reported: 2011-02-16 04:35 EST by Akira TAGOH
Modified: 2011-03-02 21:50 EST (History)
2 users (show)

See Also:
Fixed In Version: fontforge-20100501-7.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-01 20:53:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2011-02-16 04:35:17 EST
Description of problem:
This broken patch prevents to build fonts packages reported as FTBFS issues.
As per some debugging on python module for fontforge, PyObject still has Py_TPFLAGS_INT_SUBCLASS for the integer object. but after applying this patch, it's checking Py_TPFLAGS_LONG_SUBCLASS for the integer object. then seeing the strange error, "Index must be an integer or a string". even though giving an integer as index.

Version-Release number of selected component (if applicable):
fontforge-20100501-5.fc14.x86_64
python-devel-2.7-8.fc14.1.x86_64

How reproducible:
always

Steps to Reproduce:
1.try to build apanov-heuristica-fonts package say
2.
3.
  
Actual results:
fontforge script fails due to the "Index must be an integer or a string"

Expected results:
should be no errors

Additional info:
gdb logs here:


Breakpoint 2, PyFF_FontIndex (self=<fontforge.font at remote 0xbaec30>, index=
    65) at python.c:14950
14950   static PyObject *PyFF_FontIndex( PyObject *self, PyObject *index ) {
(gdb) p/x index->ob_type->tp_flags
$18 = 0x8e15fb

In intobject.h:

#define PyInt_Check(op) \
                 PyType_FastSubclass((op)->ob_type, Py_TPFLAGS_INT_SUBCLASS)

In longobject.h:

#define PyLong_Check(op) \
                PyType_FastSubclass(Py_TYPE(op), Py_TPFLAGS_LONG_SUBCLASS)

In object.h:

#define PyType_HasFeature(t,f)  (((t)->tp_flags & (f)) != 0)
#define PyType_FastSubclass(t,f)  PyType_HasFeature(t,f)

#define Py_TPFLAGS_INT_SUBCLASS         (1L<<23)
#define Py_TPFLAGS_LONG_SUBCLASS        (1L<<24)
Comment 1 Kevin Fenzi 2011-02-16 22:46:35 EST
Can you try this scratch build: 

http://koji.fedoraproject.org/koji/taskinfo?taskID=2845654

and confirm it fixes the issue?
Comment 2 Akira TAGOH 2011-02-17 04:24:07 EST
the build itself works fine. I don't do the sanity check of the generated fonts though.
Comment 3 Fedora Update System 2011-02-17 11:18:59 EST
fontforge-20100501-7.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/fontforge-20100501-7.fc15
Comment 4 Fedora Update System 2011-02-17 17:24:09 EST
fontforge-20100501-7.fc15 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fontforge'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/fontforge-20100501-7.fc15
Comment 5 Fedora Update System 2011-02-21 16:27:57 EST
fontforge-20100501-7.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/fontforge-20100501-7.fc14
Comment 6 Fedora Update System 2011-03-01 20:53:01 EST
fontforge-20100501-7.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2011-03-02 21:50:03 EST
fontforge-20100501-7.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.