Bug 67793 - Show hidden show ".directory" files. Confusing.
Summary: Show hidden show ".directory" files. Confusing.
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: nautilus (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-02 03:16 UTC by Ben Levenson
Modified: 2007-04-18 16:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 12:24:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ben Levenson 2002-07-02 03:16:33 UTC
Description of Problem:
Start Here
    |
    |_Applications
           |
           |_Applications  <--clicking here produces error "A".
           |
           | and
           |
           |_All Applications  <-- clicking here take you to applications,
                   |               but ...
                   |
                   |_All Applications  <-- there is yet another 
                                           "All Applications folder. clicking
                                           here produces error "B".

error A:

  Nautilus has no installed viewer capable of 
  displaying "applications:///.directory".
                      <OK>

error B:
  Nautilus has no installed viewer capable of displaying
  "applications:///All%20Applications/.directory".
                      <OK>

Version-Release number of selected component (if applicable):
nautilus-2.0.0-6
Limbo-re0701.1

How Reproducible:
100%

Comment 1 Ben Levenson 2002-07-02 03:33:32 UTC
hrmmm ...
I can't reproduce this with a fresh user. The bug originally manifested
when I logged in with my personal account (which was running one of the 
earlier trees). Is it a result in the change of one of the metafile formats?
Would it be useful for you to see one of my .nautilus/* or .gnome/* files?
If not, then I guess we can close this as NOTABUG.

Comment 2 Havoc Pennington 2002-07-02 05:42:13 UTC
I'm not sure I can come up with a good guess as to what might be wrong here;
perhaps caused by the menu editing stuff?

Let's leave the bug open for now, see if there are any more reports at least.

Comment 3 Ben Levenson 2002-08-20 19:21:38 UTC
this seems to be related to the following preferences option:
Show Options: Hidden files
When this feature is enabled, I consistently get duplicate entries.
1- start here
2- double click on preferences
3- edit nautilus preferences: Icon & List Views: Show Options: Hidden files
4- the open nautilus window will refresh in the background, and a preferences
   launcher will appear. If this doesn't happen, refresh the window.
5- double clicking on the new preferences launcher results in the following
   error message: "Can't Display Location | Nautilus has no installed 
   viewer... <OK>"
6- edit nautilus preferences and disable hidden files option.
7- duplicate preferences launcher should disappear.


Comment 4 Havoc Pennington 2002-08-20 19:31:19 UTC
Oh, right. Nautilus is just displaying the .directory files.
We've seen this issue before.

Comment 5 Alexander Larsson 2002-08-21 07:59:13 UTC
Yeah. that sucks. Maybe we should unconditionally not show ".directory" files?
Although that is a bit lame too.


Comment 6 Alexander Larsson 2004-10-04 12:24:59 UTC
Moved upstream:
http://bugzilla.gnome.org/show_bug.cgi?id=154454


Note You need to log in before you can comment on or make changes to this bug.