Bug 678024 - I can't install wifi card Pentagram horNet P 6132-10 [chipset Realtek RTL8188SU]
Summary: I can't install wifi card Pentagram horNet P 6132-10 [chipset Realtek RTL8188SU]
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: wireless-tools
Version: 14
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-16 14:25 UTC by Adam Przedniczek
Modified: 2012-08-16 13:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-16 12:59:59 UTC


Attachments (Terms of Use)
Content of /var/log/messages from today (760.95 KB, application/octet-stream)
2011-02-16 14:25 UTC, Adam Przedniczek
no flags Details

Description Adam Przedniczek 2011-02-16 14:25:14 UTC
Created attachment 479121 [details]
Content of /var/log/messages from today

Description of problem:
I'm trying to install wireless card Pentagram horNet P 6132-10 (with
Realtek chipset: RTL8188SU) on Fedora 14 64bit.
When I plug card to USB port, the system freezes up and I cannot do anything.
I tried to compile & install drivers from either enclosed CD or newest driver from chipset vendor site (http://218.210.127.131/downloads/downloadsView.aspx?Langid=1&PNid=21&PFid=48&Level=5&Conn=4&ProdID=228&DownTypeID=3&GetDown=false&Downloads=true#RTL8188SU).
I have even tried to do this driver installation with kmod-staging but it failed in the same way.
I'm sure that the card is in 100% OK because it works under Windows 7 64bit
and Ubuntu 10.10 32 bit.
I'm just wondering if this is because of lack of the card firmware.
Under Ubuntu I have catalogue /lib/firmware/RTL8192SE (in FC 14 I haven't) with 3 files: rtl8192sfw.bin, rtl8192sfw74.bin, rtl8192sfw492.bin.
Coping it into FC didn't help.
I should add that under this Fedora I checked another card and it's working properly.

In my humble opinion this system freeze doesn't look like kernel panic caused by kmod-staging, because:
+ the keybords LEDs aren't blinking and I haven't found it in system logs (see enclosed file)
+ I get it even without kmod-staging.


Version-Release number of selected component (if applicable):
Fedora 14 64 bit (uname -r :  2.6.35.11-83.fc14.x86_64) with rpmfusion and all updates.

Additional package kmod-staging: kmod-staging.x86_64 0:2.6.35.10-1.fc14.1

Wireless card Pentagram horNet P 6132-10 but you can test it with any card based on Realtek chipset RTL 8188 SU (it's quite common).


How reproducible: Quite well.


Steps to Reproduce:
1. Before installing try to plug card into USB port - system freezes so hard reset needed.
2. Download latest linux drivers from chipset vendor site:
http://218.210.127.131/downloads/downloadsView.aspx?Langid=1&PNid=21&PFid=48&Level=5&Conn=4&ProdID=228&DownTypeID=3&GetDown=false&Downloads=true#RTL8188SU
3. Change current user to root, and unpack tar archive from driver folder into /usr/src/
4. Change current folder to: /usr/src/rtl8712_8188_8191_8192SU_usb_linux_v2.6.6.0.20101111
5. make
6. make install
Content of Makefile:
>install:

>	install -p -m 644 $(MODULE_NAME).ko  $(MODDESTDIR)

>	/sbin/depmod -a ${KVER}

where:
> MODULE_NAME = 8712u
> KVER  := $(shell uname -r)

> MODDESTDIR := /lib/modules/$(KVER)/kernel/drivers/net/wireless/

I checked this manually and I have 8712u.ko in .../net/wireless/

7. modprobe 8712u (it returns nothing so it's OK)
8. lsmod | grep 8712u (it returns single line sth like "8712u      334223  0" so it's OK.
9. Now I have installed kernel module, but hardly had I plugged card into USB port, the system freezed up.
10. I tried point 2-9 with and without kmod-staging (no results).
11. I copied firmware (/lib/firmware/RTL8192SE) from Ubuntu 10.10 but with no results.

Actual results:
Whenever I plug this card to USB the system freezes.

Expected results:
Card working properly.

Additional info:
I enclose today's content of my /var/log/messages file.

Comment 1 Adam Przedniczek 2011-02-18 15:10:08 UTC
I've got a clue. I conducted tiny experiment and killed Network Manager. Then I plugged card. It doesn't work but al least it doesn't freeze the system.

Comment 2 Fedora End Of Life 2012-08-16 13:00:01 UTC
This message is a notice that Fedora 14 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 14. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained.  At this time, all open bugs with a Fedora 'version'
of '14' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this 
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen 
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we were unable to fix it before Fedora 14 reached end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" (top right of this page) and open it against that 
version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.