Bug 678027 - libvirtd: error: udevGetDMIData:1489 : Failed to get udev device for syspath ...
Summary: libvirtd: error: udevGetDMIData:1489 : Failed to get udev device for syspath ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt
Version: 6.1
Hardware: Unspecified
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Michal Privoznik
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-16 14:37 UTC by Milos Malik
Modified: 2011-12-06 10:54 UTC (History)
7 users (show)

Fixed In Version: libvirt-0.9.4-rc1-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: DMI data are not presented on s390(x) architectures Consequence: Running 'virsh sysinfo' failed on non-intel architectures as we are getting DMI from /sys/devices/virtual/dmi/ tree which is missing on these architectures Fix: Don't try fetching DMI info on non-intel architectures Result: 'virsh sysinfo' succeed
Clone Of:
Environment:
Last Closed: 2011-12-06 10:54:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1513 0 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2011-12-06 01:23:30 UTC

Description Milos Malik 2011-02-16 14:37:03 UTC
Description of problem:
It seems that each start of libvirtd service adds 1 error message to /var/log/messages. How can I get rid of these errors?

Version-Release number of selected component (if applicable):
libvirt-client-0.8.7-5.el6.s390x
libvirt-devel-0.8.7-5.el6.s390x
libvirt-java-0.4.7-1.el6.noarch
libvirt-java-devel-0.4.7-1.el6.noarch
libvirt-0.8.7-5.el6.s390x

How reproducible:
always on ppc64 and s390x

Steps to Reproduce:
# service libvirtd start
Starting libvirtd daemon: [  OK  ]
# ps ax | grep -e udev -e libvirtd
  579 ?        S<s    0:00 /sbin/udevd -d
38088 ?        S<     0:00 /sbin/udevd -d
38089 ?        S<     0:00 /sbin/udevd -d
39130 ?        Sl     0:00 libvirtd --daemon
39174 pts/0    S+     0:00 grep -e udev -e libvirtd
# grep dmi /var/log/messages 
Feb 16 09:09:52 ibm-z10-05 libvirtd: 09:09:52.453: 38697: error : udevGetDMIData:1489 : Failed to get udev device for syspath '/sys/devices/virtual/dmi/id' or '/sys/class/dmi/id'
Feb 16 09:23:20 ibm-z10-05 libvirtd: 09:23:20.438: 38846: error : udevGetDMIData:1489 : Failed to get udev device for syspath '/sys/devices/virtual/dmi/id' or '/sys/class/dmi/id'
Feb 16 09:25:54 ibm-z10-05 libvirtd: 09:25:54.376: 38936: error : udevGetDMIData:1489 : Failed to get udev device for syspath '/sys/devices/virtual/dmi/id' or '/sys/class/dmi/id'
Feb 16 09:29:51 ibm-z10-05 libvirtd: 09:29:51.902: 39037: error : udevGetDMIData:1489 : Failed to get udev device for syspath '/sys/devices/virtual/dmi/id' or '/sys/class/dmi/id'
Feb 16 09:34:51 ibm-z10-05 libvirtd: 09:34:51.244: 39130: error : udevGetDMIData:1489 : Failed to get udev device for syspath '/sys/devices/virtual/dmi/id' or '/sys/class/dmi/id'
# 
  
Actual results:


Expected results:

Comment 2 RHEL Program Management 2011-04-04 01:56:56 UTC
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 3 Michal Privoznik 2011-07-19 16:32:22 UTC
Patch sent and is ready to push upstream:

https://www.redhat.com/archives/libvir-list/2011-July/msg01202.html

But maybe there is a little work to be done to solve a bigger issue this bug has shown. Basically, we try to run dmidecode to satisfy 'virsh sysinfo'. But dmidecode is not available on all achitectures (e.g. ppc64), therefore there might be a followup patch to solve this. Gonna investigate tomorrow.

Comment 4 Michal Privoznik 2011-07-20 14:13:07 UTC
Moving to POST, as patch is pushed upstream.

Comment 7 Huang Wenlong 2011-08-08 01:56:07 UTC
Verify this bug in libvirt-0.9.4-1.el6.s390x

service libvirtd status
libvirtd (pid 54738) is running...
[root@ibm-z10-27 ~]# ps ax | grep -e udev -e libvirtd
600 ? S<s 0:00 /sbin/udevd -d
54738 ? Sl 0:00 libvirtd --daemon
54756 ? S< 0:00 /sbin/udevd -d
54758 ? S< 0:00 /sbin/udevd -d
56599 pts/1 S+ 0:00 grep -e udev -e libvirtd
[root@ibm-z10-27 ~]# 
[root@ibm-z10-27 ~]# grep dmi /var/log/messages 
[root@ibm-z10-27 ~]# grep dmi /var/log/libvirt/libvirtd.log
no error message

Comment 8 Michal Privoznik 2011-11-11 11:00:00 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: DMI data are not presented on s390(x) architectures

Consequence: Running 'virsh sysinfo' failed on non-intel architectures as we are getting DMI from /sys/devices/virtual/dmi/ tree which is missing on these architectures

Fix: Don't try fetching DMI info on non-intel architectures

Result: 'virsh sysinfo' succeed

Comment 9 errata-xmlrpc 2011-12-06 10:54:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1513.html


Note You need to log in before you can comment on or make changes to this bug.