Bug 67803 - /etc/X11/X link points at the wrong X server
/etc/X11/X link points at the wrong X server
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-02 04:31 EDT by Manfred Hollstein
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-17 17:11:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Manfred Hollstein 2002-07-02 04:31:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/0

Description of problem:
This happened to a customer who was installing RHL 7.3 on his desktop
system with an old graphics card ELSA Winner S3 T2D

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install RHL 7.3 on a system with an old graphics card
2.Do X configuration with graphical screen on bootup
3.Reboot system
	

Actual Results:  X won't come up. The reason is that the X configurator seems
to have detected that an XFree86-3.3.6 server is required for the old card,
but somehow failed to make the /etc/X11/X symlink point at the chosen
server; it still points at ../../usr/X11R6/bin/XFree86 which is the
XFree86-4.2.0 server and which obviously doesn't support the card.

Expected Results:  /etc/X11/X should point at ../../usr/X11R6/bin/XF86_S3 in
this case.

Additional info:
Comment 1 Miloslav Trmac 2002-07-02 13:46:17 EDT
Second that. Additionally, when a wheel mouse has been selected during
installation, IMPS/2 is in the config file, but other needed settings
Buttons 5
ZAxisMapping 4 5
are not present.

Not that it matters too much as XF3 is going away, but it might yet bite someone.
Comment 2 Jeremy Katz 2002-08-19 15:03:38 EDT
The last time I tested this code, it was doing the right thing for XFree 3 as
long as the Cards database was correct.  Since we don't use XFree 3 anymore,
it's not a problem in our current codebase

Note You need to log in before you can comment on or make changes to this bug.