Bug 678095 - If no display mode is provided, kickstart installs default to cmdline
If no display mode is provided, kickstart installs default to cmdline
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
15
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
RejectedBlocker RejectedNTH https://f...
: CommonBugs
: 683169 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-16 12:26 EST by James Laska
Modified: 2013-09-02 02:53 EDT (History)
6 users (show)

See Also:
Fixed In Version: anaconda-15.21-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-22 14:23:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda-logs.tgz (/tmp/*) (47.00 KB, application/x-gzip)
2011-02-16 12:26 EST, James Laska
no flags Details

  None (edit)
Description James Laska 2011-02-16 12:26:49 EST
Created attachment 479185 [details]
anaconda-logs.tgz (/tmp/*)

Description of problem:

This is a change from previous releases, but I'm not sure if it's intentional or not.  When performing a kickstart install that does *not* offer a display mode (e.g. 'text', 'cmdline' or 'graphical').

The previous behavior I'm familiar with was (clearly not current syntax) ...

 if ['vnc', 'text', 'cmdline'] in /proc/cmdline
    display_mode = cmdline.display_mode
 else: 
    if kickstart install:
       if kickstart.display_mode in ['vnc', 'text', 'cmdline']:
          display_mode = kickstart.display_mode
       else
          display_mode = text-mode
    else
       display_mode = VNC_install_prompt or text-mode



Version-Release number of selected component (if applicable):
 * anaconda-15.20-1

Steps to Reproduce:
1. Create a basic kickstart file that does *not* use either keyword: text, cmdline or graphical
2. Boot the installer with the proper ks= argument to initiate a kickstart install

NOTE: in my testing, I'm *not* specifying a timezone in the kickstart, so that the installer will prompt me for it.  
  
Actual results:

Greetings.
anaconda installer init version 15.20 starting
mounting /proc filesystem... done
creating /dev filesystem... done
starting udev...done
mounting /dev/pts (unix98 pty) filesystem... done
Welcome to Fedora for x86_64

   Retrieving http://dell-t5400.test.redhat.com/cobbler/ks_mirror/F-15-Alpha-x86_64/images/updates.img...
 Retrieving http://dell-t5400.test.redhat.com/cobbler/ks_mirror/F-15-Alpha-x86_64/images/product.img...

Running anaconda 15.20, the Fedora system installer - please wait.             
Examining storage devices
In interactive step timezone, can't continue


Expected results:

                    ┌───────┤ Time Zone Selection ├───────┐
                    │                                     │
                    │ In which time zone are you located? │
                    │                                     │
                    │ [ ] System clock uses UTC           │
                    │                                     │
                    │  America/Montevideo              ↑  │                     
                    │  America/Montreal                ▮  │                     
                    │  America/Montserrat              ▒  │                     
                    │  America/Nassau                  ▒  │                     
                    │  America/New York                ↓  │                     
                    │                                     │
                    │      ┌────┐          ┌──────┐       │
                    │      │ OK │          │ Back │       │
                    │      └────┘          └──────┘       │
                    │                                     │
                    │                                     │
                    └─────────────────────────────────────┘

Additional info:

 * This doesn't prevent kickstart installs, and is easily workaround-able using kickstart or a boot argument
 * Adding to the NICE-TO-HAVE (F15Alpha-accepted) list.  If a fix is available in time, we'll take it ... otherwise post-Alpha.
 * Attaching installer logs for reference

# tar -ztvf /tmp/anaconda-logs.tgz 
-rw------- root/root      1301 2011-02-16 12:14 root/anaconda-ks.cfg
-rw-r--r-- root/root     17087 2011-02-16 12:14 root/install.log
-rw-r--r-- root/root      5388 2011-02-16 12:12 root/install.log.syslog
-rw------- root/root      4263 2011-02-16 12:14 var/log/anaconda/anaconda.ifcfg.log
-rw------- root/root     37889 2011-02-16 12:14 var/log/anaconda/anaconda.log
-rw------- root/root     22984 2011-02-16 12:14 var/log/anaconda/anaconda.program.log
-rw------- root/root    121252 2011-02-16 12:14 var/log/anaconda/anaconda.storage.log
-rw------- root/root     55788 2011-02-16 12:14 var/log/anaconda/anaconda.syslog
-rw------- root/root     40449 2011-02-16 12:14 var/log/anaconda/anaconda.yum.log
Comment 1 Robyn Bergeron 2011-02-18 13:40:36 EST
Per 2011-02-18 Alpha blocker meeting:
#agreed 678095 - RejectedBlocker, RejectedNTH, document Common_F15_Bugs and accept post-Alpha
Comment 2 Chris Lumens 2011-03-08 13:21:30 EST
*** Bug 683169 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.