Bug 67812 - dateconfig crashes when used over ssh
dateconfig crashes when used over ssh
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-02 07:56 EDT by Need Real Name
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-05 16:54:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-07-02 07:56:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-10 i686)

Description of problem:
I ran up2date over ssh and it broke the X11 connection. The workaround I was
given by RedHat support to continue to use up2date was "export
DISPLAY=`hostname`:0.0". While this makes up2date work, the dateconfig program
doesn't. When I try to run it over ssh on the background, "dateconfig &" I get
the follwoing error.

[root@b006 root]# dateconfig &
[1] 1268
[root@b006 root]# Traceback (innermost last):
File "/usr/share/dateconfig/dateconfig.py", line 29, in ?
import mainWindow
File "/usr/share/dateconfig/mainWindow.py", line 29, in ?
from gtk import *
File "/usr/lib/python1.5/site-packages/gtk.py", line 29, in ?
_gtk.gtk_init()
RuntimeError: cannot open display



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. SSH into host.
2. Run "up2date -uv --nox"
3. Try running up2date or dateconfig - they fails.
4. Fix the X11 connection by running "export DISPLAY=`hostname`:0.0"
5. While up2date now works, dateconfig still doesn't
	

Actual Results:  [root@b006 root]# dateconfig &
                            [1] 1268
                            [root@b006 root]# Traceback (innermost last):
                              File "/usr/share/dateconfig/dateconfig.py", line
29, in ?
                                import mainWindow
                              File "/usr/share/dateconfig/mainWindow.py", line
29, in ?
                                from gtk import *
                              File "/usr/lib/python1.5/site-packages/gtk.py",
line 29, in ?
                                _gtk.gtk_init()
                            RuntimeError: cannot open display



Expected Results:  I should have gotten a gui windows to adjust time (clock, 
UTC, etc.)

Additional info:
Comment 1 Brent Fox 2002-07-02 14:35:30 EDT
Can you run any GUI app over the network connection?
Comment 2 Need Real Name 2002-07-02 20:13:05 EDT
I just tried that and I realized I wasn't able to. When I had trouble running up2date, I was doing it as "up2date -uv --nox". I just tried running it to call forth the GUI, and I 
got the error message "No interactive mode available". I can't seem to run any GUI app as root. I even  tried it with netscape and it gave me the error message "Error: 
Can't open display: b006:0.0". I made sure I had exported it as per RedHat support (export DISPLAY=b006:0.0) before I ran it.

I then tried running it as uid "dimitri" and I got mixed results. I tried running netscape and it worked. I tried dateconfig as uid dimitri and a pop up box requested the root 
password. When I gave it, the program crashed.

It seems that anything "root" related that has to do with a GUI will not run.

Hope this helps.
Comment 3 Brent Fox 2002-07-03 15:53:46 EDT
Ok, that's what I thought.  Something has messed up the way that the operating
system forwards the display, and this is keeping dateconfig from starting.  in
other words, dateconfig is affected by the problem, but dateconfig is not the
problem itself.

Since you say that things went wrong after running up2date, I'm going to change
the component of this bug report to up2date.  It is unlikely that up2date itself
is the problem.  More likely, one of the packages that up2date installed caused
the error, but the up2date developers will be more likely to be able to track
down the problem than I can.
Comment 4 Need Real Name 2002-07-17 00:26:33 EDT
What is the status of this issue? Were you able to reproduce the problem on your
end?
Comment 5 Adrian Likins 2003-08-06 18:27:23 EDT
unable to reproduce, need more info
Comment 6 Adrian Likins 2004-04-05 16:54:53 EDT
Not aware of any problems with this with
currently supported releases (And not
sure this was an up2date issue to begin with).

So closing "currentrelease"

Note You need to log in before you can comment on or make changes to this bug.