Bug 67815 - Incorrect search path in /etc/php.ini
Incorrect search path in /etc/php.ini
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
7.3
i386 Linux
low Severity low
: ---
: ---
Assigned To: Phil Copeland
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-02 10:08 EDT by gerry_doris
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-02 10:08:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gerry_doris 2002-07-02 10:08:49 EDT
Description of Problem:
/etc/php.ini supplies an include path of /usr/share/php.  That doesn't exist in 
Redhat 7.3.  Instead the php packages are installed in /usr/share/pear.  This 
causes problems with applications that use php ie. installing mysql support for 
squirrelmail.

Version-Release number of selected component (if applicable):


How Reproducible:
Do a cd to /usr/share/php.  The directory doesn't exist.  The packages are 
installed in /usr/share/pear.

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
I ran into this when installing mysql support for squirrelmail.  squirrelmail 
reponded with an error that it couldn't find one of the pear packages it needed 
in directory /usr/share/php which is listed as the php search path 
in /etc/php.ini.  

I fixed it by just doing a ln -s /usr/share/pear /usr/share/php

You should change the search path to replace /usr/share/php 
with /usr/share/pear.
Comment 1 Phil Copeland 2002-08-02 14:49:09 EDT
Humm
well thats the default php abuses

; UNIX: "/path1:/path2"
;include_path = ".:/php/includes"

(what were they thinking with a pathname like that)

I've inserted this into the standard php.ini file

include_path = ".:/usr/share/pear"              

I've additionally looked at php 4.2.2 and it did the same thing
rawhide currently doesn't show 7.x components that are rebuilt for errata but
this one is queued up for the next 7.x errata release. php 4.2.2-x has the fix
in and will be available from rawhide tomorrow I'd think

Phil
=--=

Note You need to log in before you can comment on or make changes to this bug.