Bug 678150 - VNC install w/ password, fails to establish password for VNC session
VNC install w/ password, fails to establish password for VNC session
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
15
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Martin Gracik
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F15Beta/F15BetaBlocker
  Show dependency treegraph
 
Reported: 2011-02-16 16:42 EST by James Laska
Modified: 2013-09-02 02:53 EDT (History)
7 users (show)

See Also:
Fixed In Version: anaconda-15.26-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-05 17:39:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (7.06 KB, text/plain)
2011-02-16 16:42 EST, James Laska
no flags Details
/tmp/vncserver.log (960 bytes, text/plain)
2011-02-16 16:43 EST, James Laska
no flags Details
/tmp/program.log (19.21 KB, text/plain)
2011-02-16 16:43 EST, James Laska
no flags Details

  None (edit)
Description James Laska 2011-02-16 16:42:41 EST
Created attachment 479216 [details]
anaconda.log

Description of problem:

When doing a VNC installation, it appears there is an error while setting the VNC session password.

Version-Release number of selected component (if applicable):
 * anaconda-15.20-1

How reproducible:


Steps to Reproduce:
1. Boot installer and initiate a VNC session
2. When prompted provide a password

  
Actual results:

On tty1 ...
16:35:30 The VNC server is now running.
setting param SecurityTypes=VncAuth failed
setting param rfbauth=/tmp/vncpassword failed
16:35:30 

I can connect to the VNC session, without being prompt for a password

Expected results:

Attempts to connect to the VNC session should be greeted with a password prompt

Additional info:
 * See attached logs
Comment 1 James Laska 2011-02-16 16:43:27 EST
Created attachment 479217 [details]
/tmp/vncserver.log
Comment 2 James Laska 2011-02-16 16:43:49 EST
Created attachment 479218 [details]
/tmp/program.log
Comment 3 Brian Lane 2011-02-16 20:25:21 EST
Does it work if you pass vncpassword=asdasd on the kernel command line?
Comment 4 Martin Gracik 2011-02-17 02:37:53 EST
This is because new vnc doesn't support changing these settings during runtime. I fixed this for rhel6 already, but forgot to push to master too, I'm sorry, my fault.
Comment 5 James Laska 2011-02-17 08:04:51 EST
(In reply to comment #3)
> Does it work if you pass vncpassword=asdasd on the kernel command line?

Doesn't seem to make a difference
Comment 6 He Rui 2011-02-22 02:41:52 EST
Reproduced on anaconda15.20.1 in 15 Alpha RC1
Comment 7 James Laska 2011-03-11 14:41:50 EST
Discussed at 2011-03-11 blocker review meeting.  This issue is fixed and available for testing in anaconda-15.21-1.  The issue has been accepted as a beta blocker.
Comment 8 James Laska 2011-03-25 11:12:52 EDT
VERIFIED, I'm not seeing this in anaconda-15.24-1 images.
Comment 9 Fedora Update System 2011-03-29 16:59:26 EDT
anaconda-15.26-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/anaconda-15.26-1.fc15
Comment 10 Fedora Update System 2011-03-29 22:26:23 EDT
Package anaconda-15.26-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-15.26-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/anaconda-15.26-1.fc15
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2011-04-05 17:38:14 EDT
anaconda-15.26-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.