Bug 67819 - missing initrd directory causes kernel panic
missing initrd directory causes kernel panic
Product: Red Hat Linux
Classification: Retired
Component: filesystem (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Aaron Brown
Depends On:
  Show dependency treegraph
Reported: 2002-07-02 10:48 EDT by Need Real Name
Modified: 2014-03-16 22:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-07-02 10:48:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-07-02 10:48:31 EDT
Description of Problem:

Kernel panics after upgrade to 2.4.18-5 from 2.4.18-4.

How Reproducible:

I haven't tried rpm -e the kernel and trying it again.

Actual Results:

The kernel paniced when it tried to pivot_root(/sysroot,/sysroot/initrd)

Additional Information:
The solution was to recreate the missing /initrd directory. rpm -V filesystem
revealed it was missing from the original package. Somehow, the directory was
deleted. If it wasn't for the above groups.google.com link, I wouldn't have
known where to begin (though in hindsight the error message does make sense).
Comment 1 Bill Nottingham 2002-07-02 11:51:57 EDT
The /initrd directory is required; that's why it's part of the filesystem package.
Comment 2 Need Real Name 2002-07-02 12:10:06 EDT
You've seemed to miss my point! Upgrading seems to break the system badly. Does
the kernel RPM mess around with /initrd directory? All I know is I upgraded,
rebooted, and got a kernel panic (with all kernels 2.4.18-{3,4,5}).
Comment 3 Bill Nottingham 2002-07-02 12:27:41 EDT
No, the kernel upgrade does not touch the /initrd directory. Recent versions of
mkinitrd make the directory when the initrd is made, but nothing that I can see
removes it.

Note You need to log in before you can comment on or make changes to this bug.