Bug 678232 - virtv2v convert windows guest with vmware-tools from esx,it will show the vmware-tools error msg
virtv2v convert windows guest with vmware-tools from esx,it will show the vmw...
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-v2v (Show other bugs)
6.1
Unspecified Unspecified
high Severity medium
: rc
: ---
Assigned To: Matthew Booth
Virtualization Bugs
:
Depends On:
Blocks: 702988 711972
  Show dependency treegraph
 
Reported: 2011-02-17 03:56 EST by Huang Wenlong
Modified: 2016-04-26 12:22 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
VMware Tools on Microsoft Windows is unable to disable itself when it detects that it is no longer running on a VMware platform. Consequently, converting a Microsoft Windows guest from VMware ESX which has VMware Tools installed will result in errors. These errors usually manifest as error messages on startup, and a "Stop Error" (also known as a BSOD) when shuting down the guest. To work around this issue, uninstall VMware Tools on Microsoft Windows guests prior to conversion.
Story Points: ---
Clone Of:
: 711972 (view as bug list)
Environment:
Last Closed: 2014-11-18 06:17:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
libgestfs_trace (9.17 KB, text/x-log)
2011-02-17 03:58 EST, Huang Wenlong
no flags Details
win2k3-vmware-tools-error-msg (15.79 KB, image/png)
2011-02-17 04:01 EST, Huang Wenlong
no flags Details
BSOD-vmware-tools (4.03 KB, image/png)
2011-02-17 05:05 EST, Huang Wenlong
no flags Details
Patch to uninstall vmware tools from firstboot.bat (3.06 KB, patch)
2011-02-23 10:32 EST, Matthew Booth
no flags Details | Diff

  None (edit)
Description Huang Wenlong 2011-02-17 03:56:57 EST
Description of problem:
virtv2v convert windows guest with vmware-tools from esx,it show the vmware-tools error msg  after enter the desktop 
if convert esx to kvm or rhevm,the bug always reproduce

Version-Release number of selected component (if applicable):
virt-v2v-0.7.1-3.el6.x86_64

libguestfs-1.7.17-12.el6.x86_64

libguestfs-*-1.7.17-12.el6.x86_64

libvirt-0.8.7-6.el6.x86_64

febootstrap-2.11-6.el6.x86_64

hivex-1.2.4-3.el6.x86_64

libguestfs-winsupport-1.0-5.el6.x86_64

augeas-libs-0.7.2-4.el6.x86_64

virtio-win-1.1.16-1.el6.noarch

How reproducible:
always

Steps to Reproduce:

make sure the guest installed the vmware-tools before conversion 

1.#LIBGUESTFS_TRACE=1 virt-v2v -ic esx://10.66.72.79/?no_verify=1 -op sdb1 -b breth0 ESX4.1-win2k3-64b >ESX4.1-win2k3-64b.log 
 

2.boot guest will show the error msg about vmware-tools 


please check the attachment 
 
  
Actual results:
the guest show the vmware-tools error msg  after enter the desktop 


Expected results:
no vmware-tools error msg window 
  

Additional info:
the error also can be found in the Event Viewer-->Windows logs-->Applications
Comment 1 Huang Wenlong 2011-02-17 03:58:23 EST
Created attachment 479283 [details]
libgestfs_trace
Comment 2 Huang Wenlong 2011-02-17 04:01:45 EST
Created attachment 479284 [details]
win2k3-vmware-tools-error-msg
Comment 4 Huang Wenlong 2011-02-17 04:27:18 EST
most guest in the ESX will be installed vmware-tools so change the priority to
high
Comment 5 Matthew Booth 2011-02-17 04:54:38 EST
This is a known issue, and unfortunately we don't have capacity to fix this right now. The workaround is to uninstall vmware tools after conversion.
Comment 6 Huang Wenlong 2011-02-17 05:02:37 EST
the guest with vmware-tools will BSOD when shutdown after conversion , but if
uninstall vmware-tool from the guest before conversion then converting it and
it will shutdown without BSOD after conversion .
please check attachment about BSOD
Comment 7 Huang Wenlong 2011-02-17 05:05:16 EST
Created attachment 479297 [details]
BSOD-vmware-tools
Comment 8 Huang Wenlong 2011-02-17 05:06:09 EST
(In reply to comment #5)
> This is a known issue, and unfortunately we don't have capacity to fix this
> right now. The workaround is to uninstall vmware tools after conversion.

thanks , I got it .
Comment 9 Matthew Booth 2011-02-23 10:32:43 EST
Created attachment 480496 [details]
Patch to uninstall vmware tools from firstboot.bat

This patch looks for vmware tools in the software hive, and adds a line to firstboot.bat to uninstall it if it's detected.

I haven't pushed this yet because I haven't actually replicated the reported behaviour. I'm just getting 0x7B BSODs for converted Windows guests at the moment. Hopefully this is an unrelated quirk of my development system.
Comment 10 Matthew Booth 2011-02-25 05:58:41 EST
The approach in the above patch doesn't work. VMware Tools cannot be uninstalled using its own installer unless it is still running on VMware virtual hardware. The error message is:

"Setup failed to determine which VMware product this virtual machine is running on. Click OK to cancel the installation."

There is no option to continue. A web search doesn't suggest any simple workarounds.
Comment 11 Matthew Booth 2011-02-25 06:18:09 EST
I saw a suggestion that vmware tools can be forcibly removed using the original VMware Tools installation media and running setup.exe /c. This doesn't work, as it only forcibly removes the installation registry entries. It doesn't unconfigure any services, or remove anything from disk.
Comment 12 Matthew Booth 2011-02-25 08:50:20 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
Converting a Microsoft Windows guest from VMware ESX which has VMware Tools installed. Note that this does not affect Linux guests.

What actions or circumstances cause the bug to present (if known).
VMware Tools on Microsoft Windows is not able to disable itself when it detects that it is no longer running on a VMware platform. It also prevents uninstallation when not running on a VMware platform.

Consequence
After conversion, VMware Tools will display several error messages on startup, and the guest will always BSOD on shutdown. It is not possible to uninstall or disable VMware Tools.

Workaround
The only currently known workaround is to uninstall VMware Tools on Microsoft Windows guests prior to conversion.

Result
Uninstalling VMware Tools causes the conversion to work normally as intended. It is not ideal, as it requires modification of the original guest. The modification is, however, reversible. VMware Tools can be reinstalled on the original guest to restore its full functionality.
Comment 13 Suzanne Yeghiayan 2011-03-28 17:16:04 EDT
Since RHEL 6.1 External Beta has begun, and this bug remains 
unresolved, it has been rejected as it is not proposed as an 
exception or blocker.

Red Hat invites you to ask your support representative to 
propose this request, if appropriate and relevant, in the 
next release of Red Hat Enterprise Linux.
Comment 14 Ryan Lerch 2011-05-08 23:36:22 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,14 +1 @@
-Cause
+VMware Tools on Microsoft Windows is unable to disable itself when it detects that it is no longer running on a VMware platform. Consequently, converting a Microsoft Windows guest from VMware ESX which has VMware Tools installed will result in errors. These errors usually manifest as error messages on startup, and a "Stop Error" (also known as a BSOD) when shuting down the guest. To work around this issue, uninstall VMware Tools on Microsoft Windows guests prior to conversion.-Converting a Microsoft Windows guest from VMware ESX which has VMware Tools installed. Note that this does not affect Linux guests.
-
-What actions or circumstances cause the bug to present (if known).
-VMware Tools on Microsoft Windows is not able to disable itself when it detects that it is no longer running on a VMware platform. It also prevents uninstallation when not running on a VMware platform.
-
-Consequence
-After conversion, VMware Tools will display several error messages on startup, and the guest will always BSOD on shutdown. It is not possible to uninstall or disable VMware Tools.
-
-Workaround
-The only currently known workaround is to uninstall VMware Tools on Microsoft Windows guests prior to conversion.
-
-Result
-Uninstalling VMware Tools causes the conversion to work normally as intended. It is not ideal, as it requires modification of the original guest. The modification is, however, reversible. VMware Tools can be reinstalled on the original guest to restore its full functionality.
Comment 20 RHEL Product and Program Management 2012-07-10 03:21:01 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 21 RHEL Product and Program Management 2012-07-10 21:59:03 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 22 RHEL Product and Program Management 2012-12-14 02:33:14 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 24 Richard W.M. Jones 2014-11-18 06:17:19 EST
Virt-v2v needs to run on the latest Red Hat Enterprise Linux release
to ensure it can correctly read and modify new guest filesystem
features.  A new version of virt-v2v is now available for RHEL 7.1.

Before RHEL 7.1 is released, follow the instructions here to
install unsupported preview packages on top of RHEL 7.0:
https://www.redhat.com/archives/libguestfs/2014-May/msg00090.html

After RHEL 7.1 is released, virt-v2v will be available in
Technical Preview.

You can run virt-v2v in a single virtual machine.  Other
requirements are covered here:
http://libguestfs.org/virt-v2v.1.html#resource-requirements

If you find a missing feature or bug in the new version of virt-v2v
please file a bug using the following link:
https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux%207&component=libguestfs

Note You need to log in before you can comment on or make changes to this bug.