Bug 678402 - F15 livemedia are checking for updates
F15 livemedia are checking for updates
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: LiveCD (Show other bugs)
15
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Matthias Clasen
AcceptedBlocker
:
: 678403 (view as bug list)
Depends On:
Blocks: F15Beta/F15BetaBlocker F15Blocker-xfce
  Show dependency treegraph
 
Reported: 2011-02-17 15:06 EST by Christoph Wickert
Modified: 2013-01-10 01:28 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-16 15:04:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christoph Wickert 2011-02-17 15:06:33 EST
Description of problem:
Summary says it all. Live media should not check for updates. I think we have a policy for that, although I cannot find it atm.

Version-Release number of selected component (if applicable):
all current F15. e.g. xfce-i386-20110217.00.iso

How reproducible:
always

Steps to Reproduce:
1. boot livemedia
Comment 1 Adam Williamson 2011-02-17 15:12:05 EST
*** Bug 678403 has been marked as a duplicate of this bug. ***
Comment 2 Adam Williamson 2011-02-17 15:12:58 EST
This blocks the beta due to release criterion:

"The desktop default update manager must not periodically check for updates when the system is booted live, but must periodically check for updates when running on an installed system"

I suspect this is because gnome-packagekit's settings have moved to gsettings.
Comment 3 Christoph Wickert 2011-02-17 17:09:43 EST
Richard, can you tell us which key are required so I can update the kickstarts? Running dconf or dconf-editor results in crashes, so I cannot look up the necessary keys.
Comment 4 Adam Williamson 2011-02-17 17:40:48 EST
it looks like all the key names are the same, in dconf /apps/gnome-packagekit/ . you can see this by looking at /usr/share/GConf/gsettings/org.gnome.packagekit.gschema.migrate , btw.
Comment 5 Richard Hughes 2011-02-18 07:30:53 EST
Christoph, Adam, we've just moved the updates checking process into a gnome-settings-daemon plugin, so at the moment you probably want to wait for the next upstream release. Then you'll want to set:

auto-update-type to 'none'
frequency-get-updates to 0
frequency-get-upgrades to 0
frequency-refresh-cache to 0
ignored-devices to '*'

all on the org.gnome.settings-daemon.plugins.updates schema.

Sorry about the key renames. It's all so we can make the updates checking stuff work well with GNOME3 now the panel icon has gone.
Comment 6 Christoph Wickert 2011-02-18 07:54:13 EST
(In reply to comment #5)
> Christoph, Adam, we've just moved the updates checking process into a
> gnome-settings-daemon plugin

This means the default Fedora package management tool now requires gnome-settings-daemon. I think sooner or later we'll need to drop it from the Xfce and LXDe spins.
Comment 7 Richard Hughes 2011-02-18 08:56:48 EST
(In reply to comment #6)
> This means the default Fedora package management tool now requires
> gnome-settings-daemon. I think sooner or later we'll need to drop it from the
> Xfce and LXDe spins.

I don't think shipping *GNOME* PackageKit is a good idea on either of those desktops. :-) KDE has a native client now (which is also heavily integrated into KDE) and so I don't think it's a big problem GNOME has an embedded client either.

That said, shipping the update viewer on XFCE might make sense, but the XFCE guys really need to make a small trivial PackageKit notification client. It's probably two days worth of code for someone familiar with XFCE.
Comment 8 Matthias Clasen 2011-02-18 15:27:02 EST
(In reply to comment #6)
> (In reply to comment #5)
> > Christoph, Adam, we've just moved the updates checking process into a
> > gnome-settings-daemon plugin
> 
> This means the default Fedora package management tool now requires
> gnome-settings-daemon. I think sooner or later we'll need to drop it from the
> Xfce and LXDe spins.

No, it doesn't. But you can do that, certainly.
Comment 9 Adam Williamson 2011-03-11 13:08:05 EST
Reviewed at the 2011-03-11 blocker review meeting. Agreed that this is a Beta blocker per criterion "The desktop default update manager must not periodically check for updates when the system is booted live, but must periodically check for updates when running on an installed system". From spin-kickstarts git log, it looks like mclasen pushed a fix for this on March 1:

commit fae7f280dfbd346627b2882bcb3d5a01de406b29
Author: Matthias Clasen <mclasen@redhat.com>
Date:   Tue Mar 1 11:04:34 2011 -0500

    Update the gnome-packagekit tweaks
    
    gnome-packagekit is no longer using GConf, so tweaking GConf keys
    has little effect. Instead disable the gnome-settings-daemon updates
    plugin.


so we should test and confirm it no longer happens with current live images.
Comment 10 Adam Williamson 2011-03-16 15:04:58 EDT
since we have a fix in for this I'm just going to set it to CLOSED, let's re-open if we actually observe this behaviour again.

Note You need to log in before you can comment on or make changes to this bug.