Bug 678404 - pki-ca :: Instance fails to start :: Error code 4
pki-ca :: Instance fails to start :: Error code 4
Status: CLOSED DUPLICATE of bug 636997
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pki-core (Show other bugs)
6.1
Unspecified Unspecified
high Severity unspecified
: rc
: ---
Assigned To: John Dennis
Chandrasekar Kannan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-17 15:12 EST by Chandrasekar Kannan
Modified: 2015-01-04 18:46 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-18 18:57:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chandrasekar Kannan 2011-02-17 15:12:55 EST
I provisioned a new rhel 6.1 x86_64 machine with build 
http://lab2.rhts.eng.bos.redhat.com/distros/vol/engineering/devarchive/redhat/rel-eng/RHEL6.1-20110210.1/6.1/

INSTALLED RPMS :: http://pastehtml.com/view/1da21wr.txt
REPO           :: http://pastehtml.com/view/1da2113.txt
CA INSTALL LOG :: http://pastehtml.com/view/1da1zq5.txt

[2011-02-17 15:02:38] [debug] run_command(/sbin/service pki-cad restart pki-ca)
[2011-02-17 15:03:11] [error] FAILED run_command("/sbin/ser[  OK  ]-cad restart pki-ca"), exit status=4 output="Stopping pki-ca: 
"tarting pki-ca: Error code 4                              [FAILED]
[2011-02-17 15:03:11] [log] Configuration Wizard listening on
https://apollo.idm.lab.bos.redhat.com:9445/ca/admin/console/config/login?pin=lHvDLJxVbl3WVGsE3djl
[2011-02-17 15:03:11] [log] After configuration, the server can be operated by the command:
/sbin/service pki-cad restart pki-ca
Comment 1 Chandrasekar Kannan 2011-02-17 15:16:00 EST
more verbose output during startup..

[root@apollo pki-ca]# /sbin/service pki-cad restart pki-ca
+ '[' -r /lib/lsb/init-functions ']'
+ . /lib/lsb/init-functions
++ lsb_release -i -s
+ DISTRIB_ID=RedHatEnterpriseServer
++ basename /var/lib/pki-ca/pki-ca
+ NAME=pki-ca
+ unset ISBOOT
+ '[' p = S -o p = K ']'
+ '[' -x /sbin/runuser ']'
+ SU=/sbin/runuser
+ TOMCAT_CFG=/etc/tomcat6/tomcat6.conf
+ '[' -r /etc/tomcat6/tomcat6.conf ']'
+ . /etc/tomcat6/tomcat6.conf
++ CATALINA_BASE=/usr/share/tomcat6
++ CATALINA_HOME=/usr/share/tomcat6
++ JASPER_HOME=/usr/share/tomcat6
++ CATALINA_TMPDIR=/var/cache/tomcat6/temp
++ TOMCAT_USER=tomcat
++ SECURITY_MANAGER=false
++ SHUTDOWN_WAIT=30
++ SHUTDOWN_VERBOSE=false
++ CATALINA_PID=/var/run/tomcat6.pid
+ '[' -r /etc/sysconfig/pki-ca ']'
+ . /etc/sysconfig/pki-ca
++ CATALINA_BASE=/var/lib/pki-ca
++ TOMCAT_USER=pkiuser
++ CATALINA_PID=/var/run/pki-ca.pid
+ CONNECTOR_PORT=8080
+ TOMCAT_SCRIPT=/usr/sbin/tomcat6
+ TOMCAT_PROG=pki-ca
+ TOMCAT_USER=pkiuser
+ TOMCAT_LOG=/var/log/tomcat6/catalina.out
+ RETVAL=0
+ RETVAL=0
+ case "$1" in
+ stop
+ echo -n 'Stopping pki-ca: '
Stopping pki-ca: + '[' -f /var/lock/subsys/pki-ca ']'
+ log_success_msg
+ /etc/redhat-lsb/lsb_log_message success
                                                           [  OK  ]
+ RETVAL=0
+ '[' RedHatEnterpriseServer = MandrivaLinux ']'
+ exit 0
+ '[' -r /lib/lsb/init-functions ']'
+ . /lib/lsb/init-functions
++ lsb_release -i -s
+ DISTRIB_ID=RedHatEnterpriseServer
++ basename /var/lib/pki-ca/pki-ca
+ NAME=pki-ca
+ unset ISBOOT
+ '[' p = S -o p = K ']'
+ '[' -x /sbin/runuser ']'
+ SU=/sbin/runuser
+ TOMCAT_CFG=/etc/tomcat6/tomcat6.conf
+ '[' -r /etc/tomcat6/tomcat6.conf ']'
+ . /etc/tomcat6/tomcat6.conf
++ CATALINA_BASE=/usr/share/tomcat6
++ CATALINA_HOME=/usr/share/tomcat6
++ JASPER_HOME=/usr/share/tomcat6
++ CATALINA_TMPDIR=/var/cache/tomcat6/temp
++ TOMCAT_USER=tomcat
++ SECURITY_MANAGER=false
++ SHUTDOWN_WAIT=30
++ SHUTDOWN_VERBOSE=false
++ CATALINA_PID=/var/run/tomcat6.pid
+ '[' -r /etc/sysconfig/pki-ca ']'
+ . /etc/sysconfig/pki-ca
++ CATALINA_BASE=/var/lib/pki-ca
++ TOMCAT_USER=pkiuser
++ CATALINA_PID=/var/run/pki-ca.pid
+ CONNECTOR_PORT=8080
+ TOMCAT_SCRIPT=/usr/sbin/tomcat6
+ TOMCAT_PROG=pki-ca
+ TOMCAT_USER=pkiuser
+ TOMCAT_LOG=/var/log/tomcat6/catalina.out
+ RETVAL=0
+ RETVAL=0
+ case "$1" in
+ start
+ echo -n 'Starting pki-ca: '
Starting pki-ca: + '[' 0 '!=' 0 ']'
+ '[' -f /var/lock/subsys/pki-ca ']'
+ export CATALINA_PID=/var/run/pki-ca.pid
+ CATALINA_PID=/var/run/pki-ca.pid
+ touch /var/run/pki-ca.pid
+ '[' 0 -eq 0 -a 0 -eq 0 ']'
+ chown pkiuser:pkiuser /var/run/pki-ca.pid
+ '[' 0 -eq 0 ']'
+ touch /var/log/tomcat6/catalina.out
+ '[' 0 -eq 0 -a 0 -eq 0 ']'
+ chown pkiuser:pkiuser /var/log/tomcat6/catalina.out
+ '[' /usr/share/tomcat6 '!=' /usr/share/tomcat6 -a 0 -eq 0 ']'
+ parseOptions
+ options=
++ awk '!/^#/ && !/^$/ { ORS=" "; print "export ", $0, ";" }' /etc/tomcat6/tomcat6.conf
+ options=' export  CATALINA_BASE="/usr/share/tomcat6" ; export  CATALINA_HOME="/usr/share/tomcat6" ; export  JASPER_HOME="/usr/share/tomcat6" ; export  CATALINA_TMPDIR="/var/cache/tomcat6/temp" ; export  TOMCAT_USER="tomcat" ; export  SECURITY_MANAGER="false" ; export  SHUTDOWN_WAIT="30" ; export  SHUTDOWN_VERBOSE="false" ; export  CATALINA_PID="/var/run/tomcat6.pid" ; '
+ '[' -r /etc/sysconfig/pki-ca ']'
++ awk '!/^#/ && !/^$/ { ORS=" "; 
                                           print "export ", $0, ";" }' /etc/sysconfig/pki-ca
+ options=' export  CATALINA_BASE="/usr/share/tomcat6" ; export  CATALINA_HOME="/usr/share/tomcat6" ; export  JASPER_HOME="/usr/share/tomcat6" ; export  CATALINA_TMPDIR="/var/cache/tomcat6/temp" ; export  TOMCAT_USER="tomcat" ; export  SECURITY_MANAGER="false" ; export  SHUTDOWN_WAIT="30" ; export  SHUTDOWN_VERBOSE="false" ; export  CATALINA_PID="/var/run/tomcat6.pid" ;  export  CATALINA_BASE="/var/lib/pki-ca" ; export  TOMCAT_USER="pkiuser" ; export  CATALINA_PID="/var/run/pki-ca.pid" ; '
+ TOMCAT_SCRIPT=' export  CATALINA_BASE="/usr/share/tomcat6" ; export  CATALINA_HOME="/usr/share/tomcat6" ; export  JASPER_HOME="/usr/share/tomcat6" ; export  CATALINA_TMPDIR="/var/cache/tomcat6/temp" ; export  TOMCAT_USER="tomcat" ; export  SECURITY_MANAGER="false" ; export  SHUTDOWN_WAIT="30" ; export  SHUTDOWN_VERBOSE="false" ; export  CATALINA_PID="/var/run/tomcat6.pid" ;  export  CATALINA_BASE="/var/lib/pki-ca" ; export  TOMCAT_USER="pkiuser" ; export  CATALINA_PID="/var/run/pki-ca.pid" ;  /usr/sbin/tomcat6'
+ '[' 0 -eq 0 -a false = true ']'
+ '[' 0 -eq 0 ']'
+ /sbin/runuser - pkiuser -c ' export  CATALINA_BASE="/usr/share/tomcat6" ; export  CATALINA_HOME="/usr/share/tomcat6" ; export  JASPER_HOME="/usr/share/tomcat6" ; export  CATALINA_TMPDIR="/var/cache/tomcat6/temp" ; export  TOMCAT_USER="tomcat" ; export  SECURITY_MANAGER="false" ; export  SHUTDOWN_WAIT="30" ; export  SHUTDOWN_VERBOSE="false" ; export  CATALINA_PID="/var/run/tomcat6.pid" ;  export  CATALINA_BASE="/var/lib/pki-ca" ; export  TOMCAT_USER="pkiuser" ; export  CATALINA_PID="/var/run/pki-ca.pid" ;  /usr/sbin/tomcat6 start'
+ RETVAL=4
+ '[' 4 -eq 0 ']'
+ log_failure_msg 'Error code 4'
+ /etc/redhat-lsb/lsb_log_message failure 'Error code 4'
Error code 4                                               [FAILED]
+ '[' RedHatEnterpriseServer = MandrivaLinux ']'
+ exit 4
[root@apollo pki-ca]#
Comment 2 John Dennis 2011-02-17 18:09:58 EST
It looks this is the bug that was fixed a while back in Fedora,

https://bugzilla.redhat.com/show_bug.cgi?id=575341

It was cloned into a RHEL bug

https://bugzilla.redhat.com/show_bug.cgi?id=636997

but if I'm reading the RHEL bz correctly it doesn't look like it's actually made through the RHEL process :-( I think we need to ping David and find out what's going on.

This isn't a CS bug, how do you want this bz to be handled?
Comment 3 John Dennis 2011-02-18 08:23:17 EST
Chandra:

It looks like the version of tomcat6 on the test machine is old, tomcat6-6.0.24-15.el6.noarch

The current version in the RHEL6.1 Nightlies is tomcat6-6.0.24-20.el6_0.noarch

We should probably try upgrading the package versions on the test machine to the latest and rerun the tests.
Comment 4 Chandrasekar Kannan 2011-02-18 13:54:09 EST
updated and tried. still fails..

[root@apollo yum.repos.d]# /sbin/service pki-cad restart pki-ca
Stopping pki-ca:                                           [  OK  ]
Starting pki-ca: Error code 4                              [FAILED]

[root@apollo yum.repos.d]# 
[root@apollo yum.repos.d]# 
[root@apollo yum.repos.d]# 
[root@apollo yum.repos.d]# 
[root@apollo yum.repos.d]# rpm -qa | grep tomcat6
tomcat6-lib-6.0.24-20.el6_0.noarch
tomcat6-servlet-2.5-api-6.0.24-20.el6_0.noarch
tomcat6-6.0.24-20.el6_0.noarch
tomcat6-jsp-2.1-api-6.0.24-20.el6_0.noarch
tomcat6-el-2.1-api-6.0.24-20.el6_0.noarch
[root@apollo yum.repos.d]#
Comment 5 Andrew Wnuk 2011-02-18 18:57:00 EST

*** This bug has been marked as a duplicate of bug 636997 ***

Note You need to log in before you can comment on or make changes to this bug.