Bug 67846 - calendar on clock needs some work
Summary: calendar on clock needs some work
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gnome-panel   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67218
TreeView+ depends on / blocked
 
Reported: 2002-07-02 21:22 UTC by Havoc Pennington
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-26 23:57:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Havoc Pennington 2002-07-02 21:22:25 UTC
The calendar on the clock shows up on the tasklist and has a silly title, 
and it needs to be sticky.

Comment 1 Havoc Pennington 2002-07-15 04:02:59 UTC
I hacked on this a bit but gtk_window_stick() doesn't seem to be working for
some reason. Needs debugging.

Comment 2 Jonathan Blandford 2002-08-26 23:57:11 UTC
It seems to be working for me.  Strangely enough, it gets a flicker of focus
when changing workspaces -- perhaps a metacity bug.  The only other feature I
can think of is to always keep the current day highlighted.

Comment 3 Jonathan Blandford 2002-08-27 00:27:03 UTC
Scratch that.  GtkCalendar is a POS -- I don't see any nice way to fix the
selection problem w/o touching GTK+.  The flicker of focus seems to be metacity
giving focus to the calendar upon changing desktops, and then noticing the mouse
is over another window and giving focus to that window.  If that's a bug, I can
open it in metacity.


Note You need to log in before you can comment on or make changes to this bug.