Bug 678510 - biosdevname segfaults when BIOS advertizes a zero sized PIRQ routing table
Summary: biosdevname segfaults when BIOS advertizes a zero sized PIRQ routing table
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: biosdevname
Version: 15
Hardware: x86_64
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Praveen K Paladugu
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedNTH
Depends On:
Blocks: F15Alpha-accepted, F15AlphaFreezeExcept
TreeView+ depends on / blocked
 
Reported: 2011-02-18 10:00 UTC by Narendra K
Modified: 2011-05-06 20:53 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-06 20:53:25 UTC


Attachments (Terms of Use)

Description Narendra K 2011-02-18 10:00:56 UTC
Description of problem:

It is reporetd that biosdevname segfaults when BIOS exposes a 0 sized PCI IRQ Routing table.


Version-Release number of selected component (if applicable):

Biosdevname-0.3.6


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results: Biosdevname segfaults


Expected results: Biosdevname handles a zero sized PIRQ table and there is no segfault.


Additional info:

This issue is fixed in v0.3.7 that Matt pushed. Please find it here -

http://linux.dell.com/files/biosdevname/permalink/biosdevname-0.3.7.tar.gz by the patch -
http://linux.dell.com/cgi-bin/gitweb/gitweb.cgi?p=biosdevname.git;a=commit;h=8f686dd1e12e4b4598a1f94f642f4497de108d32

Comment 1 Narendra K 2011-02-18 10:17:16 UTC
Proposing F15 Alpha blocker.

Comment 2 James Laska 2011-02-18 20:07:27 UTC
From the 2011-02-18 Alpha blocker review meeting
(http://meetbot.fedoraproject.org/fedora-bugzappers/2011-02-18/f15-alpha-bug-review.2011-02-18-17.00.html)

AGREED: 678510 - AcceptedNTH, updated koji build available

Comment 3 Fedora Admin XMLRPC Client 2011-05-02 15:57:38 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 4 Narendra K 2011-05-06 20:53:25 UTC
Closing this as the issue is fixed in biosdevname-0.3.7.


Note You need to log in before you can comment on or make changes to this bug.