Bug 678537 - python-markupsafe-0.18 is available
Summary: python-markupsafe-0.18 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-markupsafe
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Luke Macken
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1018333
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-18 11:30 UTC by Upstream Release Monitoring
Modified: 2016-09-20 02:41 UTC (History)
5 users (show)

Fixed In Version: python-markupsafe-0.18-1.fc18
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-10-15 06:29:03 UTC
Type: ---


Attachments (Terms of Use)

Description Upstream Release Monitoring 2011-02-18 11:30:06 UTC
Latest upstream release: 0.12
Current version in Fedora Rawhide: 0.11
URL: http://pypi.python.org/packages/source/M/MarkupSafe

Please consult the package update guidelines before you issue an update to a stable branch: https://fedoraproject.org/wiki/Package_update_guidelines

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 1 Upstream Release Monitoring 2011-07-20 10:41:37 UTC
Latest upstream release: 0.15
Current version in Fedora Rawhide: 0.11
URL: http://pypi.python.org/packages/source/M/MarkupSafe

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 2 Upstream Release Monitoring 2013-05-20 19:07:39 UTC
Latest upstream release: 0.16
Current version in Fedora Rawhide: 0.11
URL: http://pypi.python.org/packages/source/M/MarkupSafe

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 3 Upstream Release Monitoring 2013-05-22 10:24:57 UTC
Latest upstream release: 0.18
Current version in Fedora Rawhide: 0.11
URL: http://pypi.python.org/packages/source/M/MarkupSafe

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 4 Jan ONDREJ 2013-09-04 08:02:42 UTC
Todays update of pylons in Fedora stable requires at least MarkupSafe>=0.15. Please update this package.

Steps to reproduce:

python
import pkg_resources
pkg_resources.require("pylons")

Error message:
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 696, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 598, in resolve
    raise VersionConflict(dist,req) # XXX put more info here
pkg_resources.VersionConflict: (MarkupSafe 0.11 (/usr/lib64/python2.7/site-packages), Requirement.parse('MarkupSafe>=0.15'))

Please, tell me if you have no free time, I can make an update.

All turbogears2.1 projects are not functional due to problems of importing pylons library.

Comment 5 Colton 2013-09-18 17:10:48 UTC
I have confirmed that MarkupSafe is out of date in Fedora 18+. Jan, if you are using Fedora 19, you should be fine after this is fixed. On the other hand, if you are using an earlier version than Fedora 19, you will find that python-formencode will also need to be updated.
[VersionConflict] - (FormEncode 1.2.2 (/usr/lib/python2.7/site-packages), Requirement.parse('FormEncode>=1.2.4'))

Hopefully the package maintainers can resolve this shortly.

Comment 6 Jan ONDREJ 2013-10-11 17:34:01 UTC
formencode update requested in this bug:
https://bugzilla.redhat.com/show_bug.cgi?id=1018333

I contacted Kyle by email today to take this package, waiting for response.

Comment 7 Luke Macken 2013-10-12 01:21:12 UTC
I just bumped rawhide to 0.18 after testing it against Jinja2, Mako, and WebHelpers. Since Pylons 1.0.1 was pushed down to F18, we'll probably need to do the same for this.

Comment 8 Fedora Update System 2013-10-12 01:51:50 UTC
python-markupsafe-0.18-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-markupsafe-0.18-1.fc19

Comment 9 Fedora Update System 2013-10-12 01:52:05 UTC
python-markupsafe-0.18-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/python-markupsafe-0.18-1.fc20

Comment 10 Fedora Update System 2013-10-12 01:52:23 UTC
python-markupsafe-0.18-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/python-markupsafe-0.18-1.fc18

Comment 11 Fedora Update System 2013-10-13 19:58:44 UTC
Package python-markupsafe-0.18-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-markupsafe-0.18-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18990/python-markupsafe-0.18-1.fc20
then log in and leave karma (feedback).

Comment 12 Fedora Update System 2013-10-15 06:29:03 UTC
python-markupsafe-0.18-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2013-10-30 01:50:22 UTC
python-markupsafe-0.18-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2013-10-30 01:59:18 UTC
python-markupsafe-0.18-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.