Bug 67858 - nautilus desktop icons' text partly off screen
nautilus desktop icons' text partly off screen
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: nautilus (Show other bugs)
beta3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-03 04:44 EDT by Jens Petersen
Modified: 2007-04-18 12:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-23 15:44:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2002-07-03 04:44:08 EDT
Description of Problem:
The start of the text labels of the desktop icons is displayed
off screen when in a Japanese locale.

Version-Release number of selected component (if applicable):
nautilus-2.0.0-6

How Reproducible:
every time

Steps to Reproduce:
1. login into gnome session in Japanese locale
2. look at the desktop icon text

Actual Results:
The first letter of the "user's home" and the "start from here"
is off screen.

Expected Results:
The entire text should be on the screen.

Additional Information:
This is in 1152x864 if it matters.
Comment 1 Havoc Pennington 2002-07-15 00:27:40 EDT
http://bugzilla.gnome.org/show_bug.cgi?id=88188
Comment 2 Havoc Pennington 2002-08-13 19:23:43 EDT
Not specific to Japanese, and happens in nautilus 2.0.3 still. Nautilus source
code looks like it should handle this. May be related to "nautilus icons come up
in a big pile" bug. Should check whether it happens with a nautilus using core X
fonts.
Comment 3 Paul Gampe 2002-08-13 21:11:47 EDT
Startup screen in ja_JP locale also has the message text positioned below the 
half-way line.
Comment 4 Havoc Pennington 2002-08-13 21:21:39 EDT
Splash screen problem is also not CJK-specific, happens in all locales.
Comment 5 Alexander Larsson 2002-08-20 07:40:40 EDT
It looks like nautilus just looks at max-width when considering icon text width.

I think this is due to the change in wrapping. Nautilus used to wordwrap, but if
that wasn't possible, use character wrapping to never extend past min_width. I'm
not sure how to get this behaviour back with pango.
Comment 6 Havoc Pennington 2002-08-20 10:56:04 EDT
As a hack maybe we could just crank up the max width for now?
Comment 7 Owen Taylor 2002-08-20 12:27:12 EDT
See http://bugzilla.gnome.org/show_bug.cgi?id=81906 for a request
for the relevant Pango enhancement (definitely not going to happen
for Milan or pango-1.2 though.)
Comment 8 Havoc Pennington 2002-08-23 15:44:21 EDT
In nautilus 2.0.5-2 I'm putting in a lame hack to just pad the left margin 
and make this happen less often. We can increase the margin a bit if desired.

Upstream as http://bugzilla.gnome.org/show_bug.cgi?id=91547
Comment 9 Jens Petersen 2002-08-28 06:54:38 EDT
Looks much better now, thanks. (The end of "home" in Japanese is getting split
across a line now, so if the default wide could be increased a bit more it
would be even nicer, though not such a big deal.)

Note You need to log in before you can comment on or make changes to this bug.