Bug 678597 - yum xml issues, packages getting added to template that do NOT exist in repository
Summary: yum xml issues, packages getting added to template that do NOT exist in repos...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: aeolus-conductor
Version: 0.3.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: alpha
Assignee: Jan Provaznik
QA Contact: wes hayutin
URL: http://10.16.66.77/deltacloud/image_f...
Whiteboard:
Depends On:
Blocks: ce-regression ce-beta
TreeView+ depends on / blocked
 
Reported: 2011-02-18 15:05 UTC by wes hayutin
Modified: 2012-01-26 12:19 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-08 13:48:31 UTC


Attachments (Terms of Use)

Description wes hayutin 2011-02-18 15:05:15 UTC
Description of problem:
F, [2011-02-18T10:00:52.441866 #32490] FATAL -- : Packages iprutils, ppc64-utils, s390utils, silo, yaboot for asdf-image-1-1298041180.66418 appliance not found in repositories. Please check package names in appliance definition file. (RuntimeErro



root@dell-pe6950-01 imagefactoryd]# cat bg.stdout.31904-70146087513960
I, [2011-02-18T09:59:47.453735 #32458]  INFO -- : Building 'asdf-image-1-1298041180.66418' appliance for x86_64 architecture.
I, [2011-02-18T09:59:47.458707 #32458]  INFO -- : Resolving packages added to asdf-image-1-1298041180.66418 appliance definition file...
F, [2011-02-18T10:00:23.286805 #32458] FATAL -- : Packages iprutils, ppc64-utils, s390utils, silo, yaboot for asdf-image-1-1298041180.66418 appliance not found in repositories. Please check package names in appliance definition file. (RuntimeError)
/usr/lib/ruby/gems/1.8/gems/boxgrinder-build-rpm-based-os-plugin-0.0.10/lib/boxgrinder-build-rpm-based-os-plugin/rpm-dependency-validator.rb:65:in `resolve_packages'
/usr/lib/ruby/gems/1.8/gems/boxgrinder-build-rpm-based-os-plugin-0.0.10/lib/boxgrinder-build-rpm-based-os-plugin/rpm-based-os-plugin.rb:72:in `build_with_appliance_creator'
/usr/lib/ruby/gems/1.8/gems/boxgrinder-build-fedora-os-plugin-0.0.6/lib/boxgrinder-build-fedora-os-plugin/fedora-plugin.rb:39:in `execute'
/usr/lib/ruby/gems/1.8/gems/boxgrinder-build-0.7.1/lib/boxgrinder-build/plugins/base-plugin.rb:126:in `run'
/usr/lib/ruby/gems/1.8/gems/boxgrinder-build-0.7.1/lib/boxgrinder-build/appliance.rb:109:in `execute_os_plugin'
/usr/lib/ruby/gems/1.8/gems/boxgrinder-build-0.7.1/lib/boxgrinder-build/appliance.rb:82:in `execute_plugin_chain'
/usr/lib/ruby/gems/1.8/gems/boxgrinder-build-0.7.1/lib/boxgrinder-build/appliance.rb:91:in `create'
/usr/lib/ruby/gems/1.8/gems/boxgrinder-build-0.7.1/bin/boxgrinder-build:88
/usr/lib/ruby/gems/1.8/gems/commander-4.0.3/lib/commander/command.rb:180:in `call'
/usr/lib/ruby/gems/1.8/gems/commander-4.0.3/lib/commander/command.rb:180:in `call'
/usr/lib/ruby/gems/1.8/gems/commander-4.0.3/lib/commander/command.rb:155:in `run'
/usr/lib/ruby/gems/1.8/gems/commander-4.0.3/lib/commander/runner.rb:385:in `run_active_command'
/usr/lib/ruby/gems/1.8/gems/boxgrinder-build-0.7.1/bin/boxgrinder-build:43:in `run!'
/usr/lib/ruby/gems/1.8/gems/commander-4.0.3/lib/commander/delegates.rb:7:in `run!'
/usr/lib/ruby/gems/1.8/gems/commander-4.0.3/lib/commander/import.rb:10
/usr/bin/boxgrinder-build:19
I, [2011-02-18T10:00:23.933209 #32490]  INFO -- : Building 'asdf-image-1-1298041180.66418' appliance for x86_64 architecture.
I, [2011-02-18T10:00:23.994875 #32490]  INFO -- : Resolving packages added to asdf-image-1-1298041180.66418 appliance definition file...
F, [2011-02-18T10:00:52.441866 #32490] FATAL -- : Packages iprutils, ppc64-utils, s390utils, silo, yaboot for asdf-image-1-1298041180.66418 appliance not found in repositories. Please check package names in appliance definition file. (RuntimeError)
/usr/lib/ruby/gems/1.8/gems/boxgrinder-build-rpm-based-os-plugin-0.0.10/lib/boxgrinder-build-rpm-based-os-plugin/rpm-dependency-validator.rb:65:in `resolve_packages'
/usr/lib/ruby/gems/1.8/gems/boxgrinder-build-rpm-based-os-plugin-0.0.10/lib/boxgrinder-build-rpm-based-os-plugin/rpm-based-os-plugin.rb:72:in `build_with_appliance_creator'
/usr/lib/ruby/gems/1.8/gems/boxgrinder-build-fedora-os-plugin-0.0.6/lib/boxgrinder-build-fedora-os-plugin/fedora-plugin.rb:39:in `execute'
/usr/lib/ruby/gems/1.8/gems/boxgrinder-build-0.7.1/lib/boxgrinder-build/plugins/base-plugin.rb:126:in `run'
/usr/lib/ruby/gems/1.8/gems/boxgrinder-build-0.7.1/lib/boxgrinder-build/appliance.rb:109:in `execute_os_plugin'
/usr/lib/ruby/gems/1.8/gems/boxgrinder-build-0.7.1/lib/boxgrinder-build/appliance.rb:82:in `execute_plugin_chain'
/usr/lib/ruby/gems/1.8/gems/boxgrinder-build-0.7.1/lib/boxgrinder-build/appliance.rb:91:in `create'
/usr/lib/ruby/gems/1.8/gems/boxgrinder-build-0.7.1/bin/boxgrinder-build:88
/usr/lib/ruby/gems/1.8/gems/commander-4.0.3/lib/commander/command.rb:180:in `call'
/usr/lib/ruby/gems/1.8/gems/commander-4.0.3/lib/commander/command.rb:180:in `call'
/usr/lib/ruby/gems/1.8/gems/commander-4.0.3/lib/commander/command.rb:155:in `run'
/usr/lib/ruby/gems/1.8/gems/commander-4.0.3/lib/commander/runner.rb:385:in `run_active_command'
/usr/lib/ruby/gems/1.8/gems/boxgrinder-build-0.7.1/bin/boxgrinder-build:43:in `run!'
/usr/lib/ruby/gems/1.8/gems/commander-4.0.3/lib/commander/delegates.rb:7:in `run!'
/usr/lib/ruby/gems/1.8/gems/commander-4.0.3/lib/commander/import.rb:10
/usr/bin/boxgrinder-build:19
[root@dell-pe6950-01 imagefactoryd]#

Comment 1 wes hayutin 2011-02-18 15:14:13 UTC
Found in build w/ [root@dell-pe6950-01 imagefactoryd]# rpm -q deltacloud-configure
deltacloud-configure-2.0.0-3.fc14.noarch
[root@dell-pe6950-01 imagefactoryd]#

Comment 2 wes hayutin 2011-02-21 18:00:15 UTC
some bugs were not listed as "phase 2"

Comment 3 Dave Johnson 2011-02-24 21:58:42 UTC
These also...

F, [2011-02-24T16:24:30.682887 #860] FATAL -- : Packages apmd, gpart, prctl for template-image-1-1298582583.52735 appliance not found in repositories. Please check package names in appliance definition file. (RuntimeError)
/usr/lib/ruby/gems/1.8/gems/boxgrinder-build-rpm-based-os-plugin-0.0.10/lib/boxgrinder-build-rpm-based-os-plugin/rpm-dependency-validator.rb:65:in `resolve_packages'
/usr/lib/ruby/gems/1.8/gems/boxgrinder-build-rpm-based-os-plugin-0.0.10/lib/boxgrinder-build-rpm-based-os-plugin/rpm-based-os-plugin.rb:72:in `build_with_appliance_creator'
/usr/lib/ruby/gems/1.8/gems/boxgrinder-build-fedora-os-plugin-0.0.6/lib/boxgrinder-build-fedora-os-plugin/fedora-plugin.rb:39:in `execute'

Comment 4 wes hayutin 2011-03-11 16:59:01 UTC
adding to the ce-beta blocking tracker

Comment 5 wes hayutin 2011-03-17 18:29:45 UTC
This I think is resolved.. moving to on-qa

Comment 6 wes hayutin 2011-04-18 17:57:37 UTC
verified.. this is no longer relevant w/ the new image factory

[root@ip-10-80-242-101 aeolus-conductor]# rpm -qa | grep aeolus
aeolus-conductor-doc-0.0.3-6.el6.x86_64
aeolus-conductor-0.0.3-6.el6.x86_64
aeolus-conductor-daemons-0.0.3-6.el6.x86_64
aeolus-configure-2.0.0-8.el6.noarch
[root@ip-10-80-242-101 aeolus-conductor]# rpm -qa | grep factory
rubygem-image_factory_console-0.2.0-2.el6_0.20110401225248git6800ed8.noarch
rubygem-image_factory_connector-0.0.2-2.el6.20110414153545git257f8a3.noarch
imagefactory-0.1.6.2_8_gbcb427d-2.el6.noarch

Comment 7 wes hayutin 2011-08-01 19:54:21 UTC
release pending...

Comment 8 wes hayutin 2011-08-01 19:56:12 UTC
release pending...

Comment 10 wes hayutin 2011-12-08 13:48:31 UTC
perm close


Note You need to log in before you can comment on or make changes to this bug.